summaryrefslogtreecommitdiff
path: root/python-maintain-platoutils.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-maintain-platoutils.spec')
-rw-r--r--python-maintain-platoutils.spec131
1 files changed, 131 insertions, 0 deletions
diff --git a/python-maintain-platoutils.spec b/python-maintain-platoutils.spec
new file mode 100644
index 0000000..83eda3e
--- /dev/null
+++ b/python-maintain-platoutils.spec
@@ -0,0 +1,131 @@
+%global _empty_manifest_terminate_build 0
+Name: python-maintain-PlatoUtils
+Version: 0.1.3.100
+Release: 1
+Summary: 运营PlatoDB的工具
+License: MIT
+URL: https://pypi.org/project/maintain-PlatoUtils/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/ed/dc/b502eeeda44b4dd35a9e171bc224a594feaef6ef389173437703628f49ae/maintain_PlatoUtils-0.1.3.100.tar.gz
+BuildArch: noarch
+
+Requires: python3-numpy
+Requires: python3-nebula-python
+Requires: python3-nebula2-python
+Requires: python3-pandas
+Requires: python3-flashtext
+Requires: python3-gensim
+Requires: python3-tensorflow
+Requires: python3-pyecharts
+Requires: python3-stellargraph
+Requires: python3-networkx
+Requires: python3-chardet
+
+%description
+# maintian_PlatoUtils
+
+安装方式
+
+```
+pip install maintainPlatoUtils
+python setup.py install --user
+```
+
+每次更新包之后记得删除原dist内的老包,再运行:
+```
+python -m build
+twine upload dist/*
+```
+
+文件```.pypirc```置于C:/用户/<用户名>下才能使用
+
+
+%package -n python3-maintain-PlatoUtils
+Summary: 运营PlatoDB的工具
+Provides: python-maintain-PlatoUtils
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-maintain-PlatoUtils
+# maintian_PlatoUtils
+
+安装方式
+
+```
+pip install maintainPlatoUtils
+python setup.py install --user
+```
+
+每次更新包之后记得删除原dist内的老包,再运行:
+```
+python -m build
+twine upload dist/*
+```
+
+文件```.pypirc```置于C:/用户/<用户名>下才能使用
+
+
+%package help
+Summary: Development documents and examples for maintain-PlatoUtils
+Provides: python3-maintain-PlatoUtils-doc
+%description help
+# maintian_PlatoUtils
+
+安装方式
+
+```
+pip install maintainPlatoUtils
+python setup.py install --user
+```
+
+每次更新包之后记得删除原dist内的老包,再运行:
+```
+python -m build
+twine upload dist/*
+```
+
+文件```.pypirc```置于C:/用户/<用户名>下才能使用
+
+
+%prep
+%autosetup -n maintain-PlatoUtils-0.1.3.100
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-maintain-PlatoUtils -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.3.100-1
+- Package Spec generated