summaryrefslogtreecommitdiff
path: root/python-manheim-c7n-tools.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-manheim-c7n-tools.spec')
-rw-r--r--python-manheim-c7n-tools.spec107
1 files changed, 107 insertions, 0 deletions
diff --git a/python-manheim-c7n-tools.spec b/python-manheim-c7n-tools.spec
new file mode 100644
index 0000000..8c96bd8
--- /dev/null
+++ b/python-manheim-c7n-tools.spec
@@ -0,0 +1,107 @@
+%global _empty_manifest_terminate_build 0
+Name: python-manheim-c7n-tools
+Version: 1.4.3
+Release: 1
+Summary: c7n policy generation script and related utilities
+License: Apache Software License
+URL: https://github.com/manheim/manheim-c7n-tools
+Source0: https://mirrors.aliyun.com/pypi/web/packages/c1/f2/61325671ab89c09bc7ec18cc5bf379f698c2b861e93021f831a190ad6193/manheim-c7n-tools-1.4.3.tar.gz
+BuildArch: noarch
+
+Requires: python3-boto3
+Requires: python3-botocore
+Requires: python3-docutils
+Requires: python3-tabulate
+Requires: python3-pyyaml
+Requires: python3-c7n
+Requires: python3-c7n-mailer
+Requires: python3-sphinx
+Requires: python3-sphinx-rtd-theme
+Requires: python3-m2r2
+Requires: python3-mistune
+
+%description
+[![ReadTheDocs.org build status](https://readthedocs.org/projects/manheim-c7n-tools/badge/?version=latest)](https://manheim-c7n-tools.readthedocs.io/)
+[![Docker Hub Build Status](https://img.shields.io/docker/cloud/build/manheim/manheim-c7n-tools.svg)](https://hub.docker.com/r/manheim/manheim-c7n-tools)
+[![PyPI Version badge](https://img.shields.io/pypi/v/manheim-c7n-tools.svg)](https://pypi.org/project/manheim-c7n-tools/)
+Manheim's Cloud Custodian (c7n) wrapper package, policy generator, runner, and supporting tools.
+This project provides common tooling, distributed as a Docker image, for managing Manheim's cloud-custodian (c7n) tooling, including c7n itself, c7n_mailer, and our custom components. This project/repository is intended to be used (generally via the generated Docker image) alongside a configuration repository of a specific layout, containing configuration for one or more AWS accounts.
+* **Full Documentation**: <https://manheim-c7n-tools.readthedocs.io/>
+* Github Actions Builds: <https://github.com/manheim/manheim-c7n-tools/actions>
+* Docker image: <https://hub.docker.com/r/manheim/manheim-c7n-tools>
+For documentation on the upstream cloud-custodian project, please see <https://cloudcustodian.io/docs/index.html> and the source code at <https://github.com/cloud-custodian/cloud-custodian>.
+
+%package -n python3-manheim-c7n-tools
+Summary: c7n policy generation script and related utilities
+Provides: python-manheim-c7n-tools
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-manheim-c7n-tools
+[![ReadTheDocs.org build status](https://readthedocs.org/projects/manheim-c7n-tools/badge/?version=latest)](https://manheim-c7n-tools.readthedocs.io/)
+[![Docker Hub Build Status](https://img.shields.io/docker/cloud/build/manheim/manheim-c7n-tools.svg)](https://hub.docker.com/r/manheim/manheim-c7n-tools)
+[![PyPI Version badge](https://img.shields.io/pypi/v/manheim-c7n-tools.svg)](https://pypi.org/project/manheim-c7n-tools/)
+Manheim's Cloud Custodian (c7n) wrapper package, policy generator, runner, and supporting tools.
+This project provides common tooling, distributed as a Docker image, for managing Manheim's cloud-custodian (c7n) tooling, including c7n itself, c7n_mailer, and our custom components. This project/repository is intended to be used (generally via the generated Docker image) alongside a configuration repository of a specific layout, containing configuration for one or more AWS accounts.
+* **Full Documentation**: <https://manheim-c7n-tools.readthedocs.io/>
+* Github Actions Builds: <https://github.com/manheim/manheim-c7n-tools/actions>
+* Docker image: <https://hub.docker.com/r/manheim/manheim-c7n-tools>
+For documentation on the upstream cloud-custodian project, please see <https://cloudcustodian.io/docs/index.html> and the source code at <https://github.com/cloud-custodian/cloud-custodian>.
+
+%package help
+Summary: Development documents and examples for manheim-c7n-tools
+Provides: python3-manheim-c7n-tools-doc
+%description help
+[![ReadTheDocs.org build status](https://readthedocs.org/projects/manheim-c7n-tools/badge/?version=latest)](https://manheim-c7n-tools.readthedocs.io/)
+[![Docker Hub Build Status](https://img.shields.io/docker/cloud/build/manheim/manheim-c7n-tools.svg)](https://hub.docker.com/r/manheim/manheim-c7n-tools)
+[![PyPI Version badge](https://img.shields.io/pypi/v/manheim-c7n-tools.svg)](https://pypi.org/project/manheim-c7n-tools/)
+Manheim's Cloud Custodian (c7n) wrapper package, policy generator, runner, and supporting tools.
+This project provides common tooling, distributed as a Docker image, for managing Manheim's cloud-custodian (c7n) tooling, including c7n itself, c7n_mailer, and our custom components. This project/repository is intended to be used (generally via the generated Docker image) alongside a configuration repository of a specific layout, containing configuration for one or more AWS accounts.
+* **Full Documentation**: <https://manheim-c7n-tools.readthedocs.io/>
+* Github Actions Builds: <https://github.com/manheim/manheim-c7n-tools/actions>
+* Docker image: <https://hub.docker.com/r/manheim/manheim-c7n-tools>
+For documentation on the upstream cloud-custodian project, please see <https://cloudcustodian.io/docs/index.html> and the source code at <https://github.com/cloud-custodian/cloud-custodian>.
+
+%prep
+%autosetup -n manheim-c7n-tools-1.4.3
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-manheim-c7n-tools -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Jun 20 2023 Python_Bot <Python_Bot@openeuler.org> - 1.4.3-1
+- Package Spec generated