summaryrefslogtreecommitdiff
path: root/python-manuf.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-manuf.spec')
-rw-r--r--python-manuf.spec75
1 files changed, 75 insertions, 0 deletions
diff --git a/python-manuf.spec b/python-manuf.spec
new file mode 100644
index 0000000..b172682
--- /dev/null
+++ b/python-manuf.spec
@@ -0,0 +1,75 @@
+%global _empty_manifest_terminate_build 0
+Name: python-manuf
+Version: 1.1.5
+Release: 1
+Summary: Parser library for Wireshark's OUI database
+License: Apache License 2.0 or GPLv3
+URL: https://github.com/coolbho3k/manuf/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/0a/a3/9db33765f9d962de4b113c2f07b6d5bab4521ed4feec4cb97cbf18184602/manuf-1.1.5.tar.gz
+BuildArch: noarch
+
+
+%description
+[![Build Status](https://github.com/coolbho3k/manuf/workflows/test/badge.svg)](https://github.com/coolbho3k/manuf/actions)
+[![Build Status](https://badge.fury.io/py/manuf.svg)](https://pypi.org/project/manuf/)
+
+%package -n python3-manuf
+Summary: Parser library for Wireshark's OUI database
+Provides: python-manuf
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-manuf
+[![Build Status](https://github.com/coolbho3k/manuf/workflows/test/badge.svg)](https://github.com/coolbho3k/manuf/actions)
+[![Build Status](https://badge.fury.io/py/manuf.svg)](https://pypi.org/project/manuf/)
+
+%package help
+Summary: Development documents and examples for manuf
+Provides: python3-manuf-doc
+%description help
+[![Build Status](https://github.com/coolbho3k/manuf/workflows/test/badge.svg)](https://github.com/coolbho3k/manuf/actions)
+[![Build Status](https://badge.fury.io/py/manuf.svg)](https://pypi.org/project/manuf/)
+
+%prep
+%autosetup -n manuf-1.1.5
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-manuf -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 1.1.5-1
+- Package Spec generated