summaryrefslogtreecommitdiff
path: root/python-maptiler-cloud-cli.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-maptiler-cloud-cli.spec')
-rw-r--r--python-maptiler-cloud-cli.spec278
1 files changed, 278 insertions, 0 deletions
diff --git a/python-maptiler-cloud-cli.spec b/python-maptiler-cloud-cli.spec
new file mode 100644
index 0000000..bab9dc0
--- /dev/null
+++ b/python-maptiler-cloud-cli.spec
@@ -0,0 +1,278 @@
+%global _empty_manifest_terminate_build 0
+Name: python-maptiler-cloud-cli
+Version: 1.1.4
+Release: 1
+Summary: CLI utility for MapTiler Cloud
+License: MIT
+URL: https://github.com/maptiler/maptiler-cloud-cli
+Source0: https://mirrors.aliyun.com/pypi/web/packages/3b/46/08dad9825ed4e66a78221f4a392e4dbb6265732b3f4b72dfe2e8f64f5966/maptiler-cloud-cli-1.1.4.tar.gz
+BuildArch: noarch
+
+Requires: python3-click
+Requires: python3-requests
+
+%description
+# MapTiler Cloud CLI
+This tool allows you [upload map data](https://documentation.maptiler.com/hc/en-us/articles/4408129705745-How-to-upload-MBTiles-or-GeoPackage-into-MapTiler-Cloud-using-API) into [MapTiler Cloud](https://www.maptiler.com/cloud/geodata-hosting/) using [upload API](https://docs.maptiler.com/cloud/admin-api/tileset_ingest/).
+
+## Requirements
+
+- Python *version >= 3.6*
+- pip
+- venv
+
+## Installation
+
+```shell
+pip install maptiler-cloud-cli
+```
+
+## Authorization
+
+You need an API token to be able to use the tool.
+The token can be acquired from the
+[Credentials](https://cloud.maptiler.com/account/credentials/)
+section of your account administration pages in MapTiler Cloud.
+
+Specify it either on the command line or as an environment variable.
+
+```shell
+maptiler-cloud --token=MY_TOKEN ...
+```
+
+```shell
+MAPTILER_TOKEN=MY_TOKEN; maptiler-cloud ...
+```
+
+## Usage
+
+### Create a new tileset
+
+To create a new tileset, use the `tiles ingest` command.
+
+```shell
+maptiler-cloud tiles ingest v1.mbtiles
+```
+
+The command will print out the tileset ID on the last line.
+
+> :information_source: The GeoPackage must have a tile matrix set. Read the
+> [Vector tiles generating (basic)](https://documentation.maptiler.com/hc/en-us/articles/360020887038-Vector-tiles-generating-basic-)
+> article to learn how to create a valid GeoPackage or MBTiles from the
+> [MapTiler Engine application](https://www.maptiler.com/engine/).
+
+> :bulb: If you reach the tileset limit for your account, you will not be able to upload new tilesets, and you will get an error.
+> Check out our [plans](https://www.maptiler.com/cloud/plans/) to increase the number of tilesets you can have.
+
+### Update a tileset
+
+You can use the tileset ID to upload a new file to the same tileset.
+
+```shell
+maptiler-cloud tiles ingest --document-id=EXISTING_TILESET_ID v2.mbtiles
+```
+
+> :warning: This option **replaces** the tileset data with the data from the new file. It does **NOT** add the new data to the existing tileset.
+
+To learn more about using this tool, read
+[How to upload MBTiles or GeoPackage into MapTiler Cloud](https://documentation.maptiler.com/hc/en-us/articles/4408129705745-How-to-upload-MBTiles-or-GeoPackage-into-MapTiler-Cloud-using-API).
+
+For more control over tileset management, you can use the
+[Admin API](https://docs.maptiler.com/cloud/admin-api/).
+The admin API allows you to create, update or delete a tileset among other actions.
+
+
+%package -n python3-maptiler-cloud-cli
+Summary: CLI utility for MapTiler Cloud
+Provides: python-maptiler-cloud-cli
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-maptiler-cloud-cli
+# MapTiler Cloud CLI
+This tool allows you [upload map data](https://documentation.maptiler.com/hc/en-us/articles/4408129705745-How-to-upload-MBTiles-or-GeoPackage-into-MapTiler-Cloud-using-API) into [MapTiler Cloud](https://www.maptiler.com/cloud/geodata-hosting/) using [upload API](https://docs.maptiler.com/cloud/admin-api/tileset_ingest/).
+
+## Requirements
+
+- Python *version >= 3.6*
+- pip
+- venv
+
+## Installation
+
+```shell
+pip install maptiler-cloud-cli
+```
+
+## Authorization
+
+You need an API token to be able to use the tool.
+The token can be acquired from the
+[Credentials](https://cloud.maptiler.com/account/credentials/)
+section of your account administration pages in MapTiler Cloud.
+
+Specify it either on the command line or as an environment variable.
+
+```shell
+maptiler-cloud --token=MY_TOKEN ...
+```
+
+```shell
+MAPTILER_TOKEN=MY_TOKEN; maptiler-cloud ...
+```
+
+## Usage
+
+### Create a new tileset
+
+To create a new tileset, use the `tiles ingest` command.
+
+```shell
+maptiler-cloud tiles ingest v1.mbtiles
+```
+
+The command will print out the tileset ID on the last line.
+
+> :information_source: The GeoPackage must have a tile matrix set. Read the
+> [Vector tiles generating (basic)](https://documentation.maptiler.com/hc/en-us/articles/360020887038-Vector-tiles-generating-basic-)
+> article to learn how to create a valid GeoPackage or MBTiles from the
+> [MapTiler Engine application](https://www.maptiler.com/engine/).
+
+> :bulb: If you reach the tileset limit for your account, you will not be able to upload new tilesets, and you will get an error.
+> Check out our [plans](https://www.maptiler.com/cloud/plans/) to increase the number of tilesets you can have.
+
+### Update a tileset
+
+You can use the tileset ID to upload a new file to the same tileset.
+
+```shell
+maptiler-cloud tiles ingest --document-id=EXISTING_TILESET_ID v2.mbtiles
+```
+
+> :warning: This option **replaces** the tileset data with the data from the new file. It does **NOT** add the new data to the existing tileset.
+
+To learn more about using this tool, read
+[How to upload MBTiles or GeoPackage into MapTiler Cloud](https://documentation.maptiler.com/hc/en-us/articles/4408129705745-How-to-upload-MBTiles-or-GeoPackage-into-MapTiler-Cloud-using-API).
+
+For more control over tileset management, you can use the
+[Admin API](https://docs.maptiler.com/cloud/admin-api/).
+The admin API allows you to create, update or delete a tileset among other actions.
+
+
+%package help
+Summary: Development documents and examples for maptiler-cloud-cli
+Provides: python3-maptiler-cloud-cli-doc
+%description help
+# MapTiler Cloud CLI
+This tool allows you [upload map data](https://documentation.maptiler.com/hc/en-us/articles/4408129705745-How-to-upload-MBTiles-or-GeoPackage-into-MapTiler-Cloud-using-API) into [MapTiler Cloud](https://www.maptiler.com/cloud/geodata-hosting/) using [upload API](https://docs.maptiler.com/cloud/admin-api/tileset_ingest/).
+
+## Requirements
+
+- Python *version >= 3.6*
+- pip
+- venv
+
+## Installation
+
+```shell
+pip install maptiler-cloud-cli
+```
+
+## Authorization
+
+You need an API token to be able to use the tool.
+The token can be acquired from the
+[Credentials](https://cloud.maptiler.com/account/credentials/)
+section of your account administration pages in MapTiler Cloud.
+
+Specify it either on the command line or as an environment variable.
+
+```shell
+maptiler-cloud --token=MY_TOKEN ...
+```
+
+```shell
+MAPTILER_TOKEN=MY_TOKEN; maptiler-cloud ...
+```
+
+## Usage
+
+### Create a new tileset
+
+To create a new tileset, use the `tiles ingest` command.
+
+```shell
+maptiler-cloud tiles ingest v1.mbtiles
+```
+
+The command will print out the tileset ID on the last line.
+
+> :information_source: The GeoPackage must have a tile matrix set. Read the
+> [Vector tiles generating (basic)](https://documentation.maptiler.com/hc/en-us/articles/360020887038-Vector-tiles-generating-basic-)
+> article to learn how to create a valid GeoPackage or MBTiles from the
+> [MapTiler Engine application](https://www.maptiler.com/engine/).
+
+> :bulb: If you reach the tileset limit for your account, you will not be able to upload new tilesets, and you will get an error.
+> Check out our [plans](https://www.maptiler.com/cloud/plans/) to increase the number of tilesets you can have.
+
+### Update a tileset
+
+You can use the tileset ID to upload a new file to the same tileset.
+
+```shell
+maptiler-cloud tiles ingest --document-id=EXISTING_TILESET_ID v2.mbtiles
+```
+
+> :warning: This option **replaces** the tileset data with the data from the new file. It does **NOT** add the new data to the existing tileset.
+
+To learn more about using this tool, read
+[How to upload MBTiles or GeoPackage into MapTiler Cloud](https://documentation.maptiler.com/hc/en-us/articles/4408129705745-How-to-upload-MBTiles-or-GeoPackage-into-MapTiler-Cloud-using-API).
+
+For more control over tileset management, you can use the
+[Admin API](https://docs.maptiler.com/cloud/admin-api/).
+The admin API allows you to create, update or delete a tileset among other actions.
+
+
+%prep
+%autosetup -n maptiler-cloud-cli-1.1.4
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-maptiler-cloud-cli -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Jun 20 2023 Python_Bot <Python_Bot@openeuler.org> - 1.1.4-1
+- Package Spec generated