summaryrefslogtreecommitdiff
path: root/python-marshmallow-jsonapi.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-marshmallow-jsonapi.spec')
-rw-r--r--python-marshmallow-jsonapi.spec88
1 files changed, 88 insertions, 0 deletions
diff --git a/python-marshmallow-jsonapi.spec b/python-marshmallow-jsonapi.spec
new file mode 100644
index 0000000..1d0e2ea
--- /dev/null
+++ b/python-marshmallow-jsonapi.spec
@@ -0,0 +1,88 @@
+%global _empty_manifest_terminate_build 0
+Name: python-marshmallow-jsonapi
+Version: 0.24.0
+Release: 1
+Summary: JSON API 1.0 (https://jsonapi.org) formatting with marshmallow
+License: MIT
+URL: https://github.com/marshmallow-code/marshmallow-jsonapi
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/42/8e/5148bdc8ffb44e03a259ac4c824d568ad9ce2653c63e216382ee94308bc3/marshmallow-jsonapi-0.24.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-marshmallow
+Requires: python3-pytest
+Requires: python3-mock
+Requires: python3-faker
+Requires: python3-Flask
+Requires: python3-flake8
+Requires: python3-flake8-bugbear
+Requires: python3-pre-commit
+Requires: python3-tox
+Requires: python3-flake8
+Requires: python3-flake8-bugbear
+Requires: python3-pre-commit
+Requires: python3-pytest
+Requires: python3-mock
+Requires: python3-faker
+Requires: python3-Flask
+
+%description
+ pip install marshmallow-jsonapi
+
+%package -n python3-marshmallow-jsonapi
+Summary: JSON API 1.0 (https://jsonapi.org) formatting with marshmallow
+Provides: python-marshmallow-jsonapi
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-marshmallow-jsonapi
+ pip install marshmallow-jsonapi
+
+%package help
+Summary: Development documents and examples for marshmallow-jsonapi
+Provides: python3-marshmallow-jsonapi-doc
+%description help
+ pip install marshmallow-jsonapi
+
+%prep
+%autosetup -n marshmallow-jsonapi-0.24.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-marshmallow-jsonapi -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 0.24.0-1
+- Package Spec generated