summaryrefslogtreecommitdiff
path: root/python-mkdocs-rss-plugin.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-05 14:02:29 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-05 14:02:29 +0000
commit3178fdf002ed9e5e02ef3f5ddb7c66c73212ca39 (patch)
treeb722607adf1d34364125f3218ac246b20aef167a /python-mkdocs-rss-plugin.spec
parent373badab2a14e78bc8172cfdade21195e301ca55 (diff)
automatic import of python-mkdocs-rss-pluginopeneuler20.03
Diffstat (limited to 'python-mkdocs-rss-plugin.spec')
-rw-r--r--python-mkdocs-rss-plugin.spec371
1 files changed, 371 insertions, 0 deletions
diff --git a/python-mkdocs-rss-plugin.spec b/python-mkdocs-rss-plugin.spec
new file mode 100644
index 0000000..4a0d1aa
--- /dev/null
+++ b/python-mkdocs-rss-plugin.spec
@@ -0,0 +1,371 @@
+%global _empty_manifest_terminate_build 0
+Name: python-mkdocs-rss-plugin
+Version: 1.6.0
+Release: 1
+Summary: MkDocs plugin which generates a static RSS feed using git log and page.meta.
+License: MIT
+URL: https://pypi.org/project/mkdocs-rss-plugin/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/1e/6c/83ecfb58f9b996e4aa1346567fafd32234f6cd28055efed7dba5c39f9fe6/mkdocs-rss-plugin-1.6.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-GitPython
+Requires: python3-mkdocs
+Requires: python3-pytz
+Requires: python3-tzdata
+Requires: python3-black
+Requires: python3-feedparser
+Requires: python3-flake8
+Requires: python3-pre-commit
+Requires: python3-pytest-cov
+Requires: python3-validator-collection
+Requires: python3-mkdocs-bootswatch
+Requires: python3-mkdocs-minify-plugin
+Requires: python3-pygments
+Requires: python3-pymdown-extensions
+
+%description
+# MkDocs RSS plugin
+
+[![PyPi version badge](https://badgen.net/pypi/v/mkdocs-rss-plugin)](https://pypi.org/project/mkdocs-rss-plugin/)
+[![PyPI - Downloads](https://img.shields.io/pypi/dm/mkdocs-rss-plugin)](https://pypi.org/project/mkdocs-rss-plugin/)
+[![PyPI - Python Version](https://img.shields.io/pypi/pyversions/mkdocs-rss-plugin)](https://pypi.org/project/mkdocs-rss-plugin/)
+
+[![codecov](https://codecov.io/gh/Guts/mkdocs-rss-plugin/branch/main/graph/badge.svg?token=A0XPLKiwiW)](https://codecov.io/gh/Guts/mkdocs-rss-plugin)
+[![Code style: black](https://img.shields.io/badge/code%20style-black-000000.svg)](https://github.com/psf/black)
+[![flake8](https://img.shields.io/badge/linter-flake8-green)](https://flake8.pycqa.org/)
+[![Imports: isort](https://img.shields.io/badge/%20imports-isort-%231674b1?style=flat&labelColor=ef8336)](https://pycqa.github.io/isort/)
+[![pre-commit](https://img.shields.io/badge/pre--commit-enabled-brightgreen?logo=pre-commit&logoColor=white)](https://github.com/pre-commit/pre-commit)
+[![pre-commit.ci status](https://results.pre-commit.ci/badge/github/Guts/mkdocs-rss-plugin/master.svg)](https://results.pre-commit.ci/latest/github/Guts/mkdocs-rss-plugin/master)
+[![📚 Documentation](https://github.com/Guts/mkdocs-rss-plugin/actions/workflows/documentation.yml/badge.svg)](https://github.com/Guts/mkdocs-rss-plugin/actions/workflows/documentation.yml)
+
+A plugin for [MkDocs](https://www.mkdocs.org), the static site generator, which creates [RSS 2.0](https://wikipedia.org/wiki/RSS) feeds using the creation and modification dates from [git log](https://git-scm.com/docs/git-log) and page metadata ([YAML frontmatter](https://www.mkdocs.org/user-guide/writing-your-docs/#yaml-style-meta-data)).
+
+## Usage
+
+Minimal [`mkdocs.yml` configuration](https://www.mkdocs.org/user-guide/configuration/#project-information):
+
+```yaml
+site_description: required. Used as feed mandatory channel description.
+site_name: required. Used as feed mandatory channel title and items source URL label.
+site_url: required. Used to build feed items URLs.
+```
+
+Minimal plugin option:
+
+```yaml
+plugins:
+ - rss
+```
+
+Full options:
+
+```yaml
+plugins:
+ - rss:
+ abstract_chars_count: 160 # -1 for full content
+ categories:
+ - tags
+ comments_path: "#__comments"
+ date_from_meta:
+ as_creation: "date"
+ as_update: false
+ datetime_format: "%Y-%m-%d %H:%M"
+ default_timezone: Europe/Paris
+ default_time: "09:30"
+ enabled: true
+ feed_ttl: 1440
+ image: https://upload.wikimedia.org/wikipedia/commons/thumb/4/43/Feed-icon.svg/128px-Feed-icon.svg.png
+ length: 20
+ pretty_print: false
+ match_path: ".*"
+ url_parameters:
+ utm_source: "documentation"
+ utm_medium: "RSS"
+ utm_campaign: "feed-syndication"
+```
+
+For further information, [see the user documentation](https://guts.github.io/mkdocs-rss-plugin/).
+
+Following initiative from the author of Material for MkDocs, this plugin provides its own JSON schema to validate configuration: [source](https://github.com/Guts/mkdocs-rss-plugin/blob/main/docs/schema.json) - [documentation](https://guts.github.io/mkdocs-rss-plugin/schema.json).
+
+## Development
+
+Clone the repository:
+
+```bash
+# install development dependencies
+python -m pip install -U -r requirements/development.txt
+# alternatively: pip install -e .[dev]
+
+# install project as editable
+python -m pip install -e .
+
+# install git hooks
+pre-commit install
+
+# run tests
+pytest
+
+# install dependencies for documentation
+python -m pip install -U -r requirements/documentation.txt
+# alternatively: pip install -e .[doc]
+```
+
+Then follow the [contribution guidelines](CONTRIBUTING.md).
+
+## Release workflow
+
+1. Fill the `CHANGELOG.md`
+1. Change the version number in `__about__.py`
+1. Apply a git tag with the relevant version: `git tag -a 0.3.0 {git commit hash} -m "New awesome feature"`
+1. Push tag to main branch: `git push origin 0.3.0`
+
+
+%package -n python3-mkdocs-rss-plugin
+Summary: MkDocs plugin which generates a static RSS feed using git log and page.meta.
+Provides: python-mkdocs-rss-plugin
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-mkdocs-rss-plugin
+# MkDocs RSS plugin
+
+[![PyPi version badge](https://badgen.net/pypi/v/mkdocs-rss-plugin)](https://pypi.org/project/mkdocs-rss-plugin/)
+[![PyPI - Downloads](https://img.shields.io/pypi/dm/mkdocs-rss-plugin)](https://pypi.org/project/mkdocs-rss-plugin/)
+[![PyPI - Python Version](https://img.shields.io/pypi/pyversions/mkdocs-rss-plugin)](https://pypi.org/project/mkdocs-rss-plugin/)
+
+[![codecov](https://codecov.io/gh/Guts/mkdocs-rss-plugin/branch/main/graph/badge.svg?token=A0XPLKiwiW)](https://codecov.io/gh/Guts/mkdocs-rss-plugin)
+[![Code style: black](https://img.shields.io/badge/code%20style-black-000000.svg)](https://github.com/psf/black)
+[![flake8](https://img.shields.io/badge/linter-flake8-green)](https://flake8.pycqa.org/)
+[![Imports: isort](https://img.shields.io/badge/%20imports-isort-%231674b1?style=flat&labelColor=ef8336)](https://pycqa.github.io/isort/)
+[![pre-commit](https://img.shields.io/badge/pre--commit-enabled-brightgreen?logo=pre-commit&logoColor=white)](https://github.com/pre-commit/pre-commit)
+[![pre-commit.ci status](https://results.pre-commit.ci/badge/github/Guts/mkdocs-rss-plugin/master.svg)](https://results.pre-commit.ci/latest/github/Guts/mkdocs-rss-plugin/master)
+[![📚 Documentation](https://github.com/Guts/mkdocs-rss-plugin/actions/workflows/documentation.yml/badge.svg)](https://github.com/Guts/mkdocs-rss-plugin/actions/workflows/documentation.yml)
+
+A plugin for [MkDocs](https://www.mkdocs.org), the static site generator, which creates [RSS 2.0](https://wikipedia.org/wiki/RSS) feeds using the creation and modification dates from [git log](https://git-scm.com/docs/git-log) and page metadata ([YAML frontmatter](https://www.mkdocs.org/user-guide/writing-your-docs/#yaml-style-meta-data)).
+
+## Usage
+
+Minimal [`mkdocs.yml` configuration](https://www.mkdocs.org/user-guide/configuration/#project-information):
+
+```yaml
+site_description: required. Used as feed mandatory channel description.
+site_name: required. Used as feed mandatory channel title and items source URL label.
+site_url: required. Used to build feed items URLs.
+```
+
+Minimal plugin option:
+
+```yaml
+plugins:
+ - rss
+```
+
+Full options:
+
+```yaml
+plugins:
+ - rss:
+ abstract_chars_count: 160 # -1 for full content
+ categories:
+ - tags
+ comments_path: "#__comments"
+ date_from_meta:
+ as_creation: "date"
+ as_update: false
+ datetime_format: "%Y-%m-%d %H:%M"
+ default_timezone: Europe/Paris
+ default_time: "09:30"
+ enabled: true
+ feed_ttl: 1440
+ image: https://upload.wikimedia.org/wikipedia/commons/thumb/4/43/Feed-icon.svg/128px-Feed-icon.svg.png
+ length: 20
+ pretty_print: false
+ match_path: ".*"
+ url_parameters:
+ utm_source: "documentation"
+ utm_medium: "RSS"
+ utm_campaign: "feed-syndication"
+```
+
+For further information, [see the user documentation](https://guts.github.io/mkdocs-rss-plugin/).
+
+Following initiative from the author of Material for MkDocs, this plugin provides its own JSON schema to validate configuration: [source](https://github.com/Guts/mkdocs-rss-plugin/blob/main/docs/schema.json) - [documentation](https://guts.github.io/mkdocs-rss-plugin/schema.json).
+
+## Development
+
+Clone the repository:
+
+```bash
+# install development dependencies
+python -m pip install -U -r requirements/development.txt
+# alternatively: pip install -e .[dev]
+
+# install project as editable
+python -m pip install -e .
+
+# install git hooks
+pre-commit install
+
+# run tests
+pytest
+
+# install dependencies for documentation
+python -m pip install -U -r requirements/documentation.txt
+# alternatively: pip install -e .[doc]
+```
+
+Then follow the [contribution guidelines](CONTRIBUTING.md).
+
+## Release workflow
+
+1. Fill the `CHANGELOG.md`
+1. Change the version number in `__about__.py`
+1. Apply a git tag with the relevant version: `git tag -a 0.3.0 {git commit hash} -m "New awesome feature"`
+1. Push tag to main branch: `git push origin 0.3.0`
+
+
+%package help
+Summary: Development documents and examples for mkdocs-rss-plugin
+Provides: python3-mkdocs-rss-plugin-doc
+%description help
+# MkDocs RSS plugin
+
+[![PyPi version badge](https://badgen.net/pypi/v/mkdocs-rss-plugin)](https://pypi.org/project/mkdocs-rss-plugin/)
+[![PyPI - Downloads](https://img.shields.io/pypi/dm/mkdocs-rss-plugin)](https://pypi.org/project/mkdocs-rss-plugin/)
+[![PyPI - Python Version](https://img.shields.io/pypi/pyversions/mkdocs-rss-plugin)](https://pypi.org/project/mkdocs-rss-plugin/)
+
+[![codecov](https://codecov.io/gh/Guts/mkdocs-rss-plugin/branch/main/graph/badge.svg?token=A0XPLKiwiW)](https://codecov.io/gh/Guts/mkdocs-rss-plugin)
+[![Code style: black](https://img.shields.io/badge/code%20style-black-000000.svg)](https://github.com/psf/black)
+[![flake8](https://img.shields.io/badge/linter-flake8-green)](https://flake8.pycqa.org/)
+[![Imports: isort](https://img.shields.io/badge/%20imports-isort-%231674b1?style=flat&labelColor=ef8336)](https://pycqa.github.io/isort/)
+[![pre-commit](https://img.shields.io/badge/pre--commit-enabled-brightgreen?logo=pre-commit&logoColor=white)](https://github.com/pre-commit/pre-commit)
+[![pre-commit.ci status](https://results.pre-commit.ci/badge/github/Guts/mkdocs-rss-plugin/master.svg)](https://results.pre-commit.ci/latest/github/Guts/mkdocs-rss-plugin/master)
+[![📚 Documentation](https://github.com/Guts/mkdocs-rss-plugin/actions/workflows/documentation.yml/badge.svg)](https://github.com/Guts/mkdocs-rss-plugin/actions/workflows/documentation.yml)
+
+A plugin for [MkDocs](https://www.mkdocs.org), the static site generator, which creates [RSS 2.0](https://wikipedia.org/wiki/RSS) feeds using the creation and modification dates from [git log](https://git-scm.com/docs/git-log) and page metadata ([YAML frontmatter](https://www.mkdocs.org/user-guide/writing-your-docs/#yaml-style-meta-data)).
+
+## Usage
+
+Minimal [`mkdocs.yml` configuration](https://www.mkdocs.org/user-guide/configuration/#project-information):
+
+```yaml
+site_description: required. Used as feed mandatory channel description.
+site_name: required. Used as feed mandatory channel title and items source URL label.
+site_url: required. Used to build feed items URLs.
+```
+
+Minimal plugin option:
+
+```yaml
+plugins:
+ - rss
+```
+
+Full options:
+
+```yaml
+plugins:
+ - rss:
+ abstract_chars_count: 160 # -1 for full content
+ categories:
+ - tags
+ comments_path: "#__comments"
+ date_from_meta:
+ as_creation: "date"
+ as_update: false
+ datetime_format: "%Y-%m-%d %H:%M"
+ default_timezone: Europe/Paris
+ default_time: "09:30"
+ enabled: true
+ feed_ttl: 1440
+ image: https://upload.wikimedia.org/wikipedia/commons/thumb/4/43/Feed-icon.svg/128px-Feed-icon.svg.png
+ length: 20
+ pretty_print: false
+ match_path: ".*"
+ url_parameters:
+ utm_source: "documentation"
+ utm_medium: "RSS"
+ utm_campaign: "feed-syndication"
+```
+
+For further information, [see the user documentation](https://guts.github.io/mkdocs-rss-plugin/).
+
+Following initiative from the author of Material for MkDocs, this plugin provides its own JSON schema to validate configuration: [source](https://github.com/Guts/mkdocs-rss-plugin/blob/main/docs/schema.json) - [documentation](https://guts.github.io/mkdocs-rss-plugin/schema.json).
+
+## Development
+
+Clone the repository:
+
+```bash
+# install development dependencies
+python -m pip install -U -r requirements/development.txt
+# alternatively: pip install -e .[dev]
+
+# install project as editable
+python -m pip install -e .
+
+# install git hooks
+pre-commit install
+
+# run tests
+pytest
+
+# install dependencies for documentation
+python -m pip install -U -r requirements/documentation.txt
+# alternatively: pip install -e .[doc]
+```
+
+Then follow the [contribution guidelines](CONTRIBUTING.md).
+
+## Release workflow
+
+1. Fill the `CHANGELOG.md`
+1. Change the version number in `__about__.py`
+1. Apply a git tag with the relevant version: `git tag -a 0.3.0 {git commit hash} -m "New awesome feature"`
+1. Push tag to main branch: `git push origin 0.3.0`
+
+
+%prep
+%autosetup -n mkdocs-rss-plugin-1.6.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-mkdocs-rss-plugin -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 1.6.0-1
+- Package Spec generated