summaryrefslogtreecommitdiff
path: root/python-mlinsights.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-mlinsights.spec')
-rw-r--r--python-mlinsights.spec123
1 files changed, 123 insertions, 0 deletions
diff --git a/python-mlinsights.spec b/python-mlinsights.spec
new file mode 100644
index 0000000..3660092
--- /dev/null
+++ b/python-mlinsights.spec
@@ -0,0 +1,123 @@
+%global _empty_manifest_terminate_build 0
+Name: python-mlinsights
+Version: 0.3.649
+Release: 1
+Summary: Extends scikit-learn with a couple of new models, transformers, metrics, plotting.
+License: MIT
+URL: http://www.xavierdupre.fr/app/mlinsights/helpsphinx/index.html
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/8d/27/716cd86f23dffacfae3bced0797f1c06c34eddedab13f8532952b705a72e/mlinsights-0.3.649.tar.gz
+
+Requires: python3-cython
+Requires: python3-scikit-learn
+Requires: python3-pandas
+Requires: python3-scipy
+Requires: python3-matplotlib
+Requires: python3-pandas-streaming
+Requires: python3-numpy
+
+%description
+*mlinsights* extends *scikit-learn* with a couple of new models,
+transformers, metrics, plotting. It provides new trainers such as
+*QuantileLinearRegression* which trains a linear regression with *L1* norm
+non-linear correlation based on decision trees, or
+*QuantileMLPRegressor* a modification of scikit-learn's MLPRegressor
+which trains a multi-layer perceptron with *L1* norm.
+It also explores *PredictableTSNE* which trains a supervized
+model to replicate *t-SNE* results or a *PiecewiseRegression*
+which partitions the data before fitting a model on each bucket.
+* `GitHub/mlinsights <https://github.com/sdpython/mlinsights/>`_
+* `documentation <http://www.xavierdupre.fr/app/mlinsights/helpsphinx/index.html>`_
+* `Blog <http://www.xavierdupre.fr/app/mlinsights/helpsphinx/blog/main_0000.html#ap-main-0>`_
+Function ``pipeline2dot`` converts a pipeline into a graph:
+ from mlinsights.plotting import pipeline2dot
+ dot = pipeline2dot(clf, df)
+
+%package -n python3-mlinsights
+Summary: Extends scikit-learn with a couple of new models, transformers, metrics, plotting.
+Provides: python-mlinsights
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+BuildRequires: python3-cffi
+BuildRequires: gcc
+BuildRequires: gdb
+%description -n python3-mlinsights
+*mlinsights* extends *scikit-learn* with a couple of new models,
+transformers, metrics, plotting. It provides new trainers such as
+*QuantileLinearRegression* which trains a linear regression with *L1* norm
+non-linear correlation based on decision trees, or
+*QuantileMLPRegressor* a modification of scikit-learn's MLPRegressor
+which trains a multi-layer perceptron with *L1* norm.
+It also explores *PredictableTSNE* which trains a supervized
+model to replicate *t-SNE* results or a *PiecewiseRegression*
+which partitions the data before fitting a model on each bucket.
+* `GitHub/mlinsights <https://github.com/sdpython/mlinsights/>`_
+* `documentation <http://www.xavierdupre.fr/app/mlinsights/helpsphinx/index.html>`_
+* `Blog <http://www.xavierdupre.fr/app/mlinsights/helpsphinx/blog/main_0000.html#ap-main-0>`_
+Function ``pipeline2dot`` converts a pipeline into a graph:
+ from mlinsights.plotting import pipeline2dot
+ dot = pipeline2dot(clf, df)
+
+%package help
+Summary: Development documents and examples for mlinsights
+Provides: python3-mlinsights-doc
+%description help
+*mlinsights* extends *scikit-learn* with a couple of new models,
+transformers, metrics, plotting. It provides new trainers such as
+*QuantileLinearRegression* which trains a linear regression with *L1* norm
+non-linear correlation based on decision trees, or
+*QuantileMLPRegressor* a modification of scikit-learn's MLPRegressor
+which trains a multi-layer perceptron with *L1* norm.
+It also explores *PredictableTSNE* which trains a supervized
+model to replicate *t-SNE* results or a *PiecewiseRegression*
+which partitions the data before fitting a model on each bucket.
+* `GitHub/mlinsights <https://github.com/sdpython/mlinsights/>`_
+* `documentation <http://www.xavierdupre.fr/app/mlinsights/helpsphinx/index.html>`_
+* `Blog <http://www.xavierdupre.fr/app/mlinsights/helpsphinx/blog/main_0000.html#ap-main-0>`_
+Function ``pipeline2dot`` converts a pipeline into a graph:
+ from mlinsights.plotting import pipeline2dot
+ dot = pipeline2dot(clf, df)
+
+%prep
+%autosetup -n mlinsights-0.3.649
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-mlinsights -f filelist.lst
+%dir %{python3_sitearch}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 17 2023 Python_Bot <Python_Bot@openeuler.org> - 0.3.649-1
+- Package Spec generated