summaryrefslogtreecommitdiff
path: root/python-momba-engine.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-momba-engine.spec')
-rw-r--r--python-momba-engine.spec104
1 files changed, 104 insertions, 0 deletions
diff --git a/python-momba-engine.spec b/python-momba-engine.spec
new file mode 100644
index 0000000..52447fe
--- /dev/null
+++ b/python-momba-engine.spec
@@ -0,0 +1,104 @@
+%global _empty_manifest_terminate_build 0
+Name: python-momba-engine
+Version: 0.6.7
+Release: 1
+Summary: A Python package supercharging Momba with computing capabilities.
+License: MIT OR Apache-2.0
+URL: https://pypi.org/project/momba-engine/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/e5/42/41f9114291fd233b83d0c54d44e534cb36fae53f3848b84c974ec35ec001/momba_engine-0.6.7.tar.gz
+
+
+%description
+# Momba Engine
+
+[![PyPi Package](https://img.shields.io/pypi/v/momba_engine.svg?label=latest%20version)](https://pypi.python.org/pypi/momba_engine)
+
+*Momba Engine* is a Python package partially written in Rust using [PyO3](https://pyo3.rs/).
+While Python is a great language for many purposes, it certainly lacks the speed necessary for computing with large and complex models.
+Hence, Momba Engine implements carefully chosen functionality, such as state space exploration, in Rust combining the convenience of Python with the raw power of Rust.
+Note that we do not provide any stability guarantees for the API of Momba Engine.
+The functionality is exposed as part of [Momba](https://https://github.com/koehlma/momba/)'s public API.
+
+
+
+%package -n python3-momba-engine
+Summary: A Python package supercharging Momba with computing capabilities.
+Provides: python-momba-engine
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+BuildRequires: python3-cffi
+BuildRequires: gcc
+BuildRequires: gdb
+%description -n python3-momba-engine
+# Momba Engine
+
+[![PyPi Package](https://img.shields.io/pypi/v/momba_engine.svg?label=latest%20version)](https://pypi.python.org/pypi/momba_engine)
+
+*Momba Engine* is a Python package partially written in Rust using [PyO3](https://pyo3.rs/).
+While Python is a great language for many purposes, it certainly lacks the speed necessary for computing with large and complex models.
+Hence, Momba Engine implements carefully chosen functionality, such as state space exploration, in Rust combining the convenience of Python with the raw power of Rust.
+Note that we do not provide any stability guarantees for the API of Momba Engine.
+The functionality is exposed as part of [Momba](https://https://github.com/koehlma/momba/)'s public API.
+
+
+
+%package help
+Summary: Development documents and examples for momba-engine
+Provides: python3-momba-engine-doc
+%description help
+# Momba Engine
+
+[![PyPi Package](https://img.shields.io/pypi/v/momba_engine.svg?label=latest%20version)](https://pypi.python.org/pypi/momba_engine)
+
+*Momba Engine* is a Python package partially written in Rust using [PyO3](https://pyo3.rs/).
+While Python is a great language for many purposes, it certainly lacks the speed necessary for computing with large and complex models.
+Hence, Momba Engine implements carefully chosen functionality, such as state space exploration, in Rust combining the convenience of Python with the raw power of Rust.
+Note that we do not provide any stability guarantees for the API of Momba Engine.
+The functionality is exposed as part of [Momba](https://https://github.com/koehlma/momba/)'s public API.
+
+
+
+%prep
+%autosetup -n momba-engine-0.6.7
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-momba-engine -f filelist.lst
+%dir %{python3_sitearch}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed Apr 12 2023 Python_Bot <Python_Bot@openeuler.org> - 0.6.7-1
+- Package Spec generated