summaryrefslogtreecommitdiff
path: root/python-mopidy.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-mopidy.spec')
-rw-r--r--python-mopidy.spec387
1 files changed, 387 insertions, 0 deletions
diff --git a/python-mopidy.spec b/python-mopidy.spec
new file mode 100644
index 0000000..4391d5b
--- /dev/null
+++ b/python-mopidy.spec
@@ -0,0 +1,387 @@
+%global _empty_manifest_terminate_build 0
+Name: python-Mopidy
+Version: 3.4.1
+Release: 1
+Summary: Mopidy is an extensible music server written in Python
+License: Apache License, Version 2.0
+URL: https://mopidy.com/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/c1/43/b450251b22c3b620a0f12bf7cb60db2ae160c5c535ce5dbe09c8ac35e1e3/Mopidy-3.4.1.tar.gz
+BuildArch: noarch
+
+Requires: python3-Pykka
+Requires: python3-requests
+Requires: python3-setuptools
+Requires: python3-tornado
+Requires: python3-pygraphviz
+Requires: python3-sphinx
+Requires: python3-sphinx-rtd-theme
+Requires: python3-black
+Requires: python3-check-manifest
+Requires: python3-flake8
+Requires: python3-flake8-black
+Requires: python3-flake8-bugbear
+Requires: python3-flake8-isort
+Requires: python3-isort
+Requires: python3-mypy
+Requires: python3-pep8-naming
+Requires: python3-types-requests
+Requires: python3-types-setuptools
+Requires: python3-pytest
+Requires: python3-pytest-cov
+Requires: python3-responses
+Requires: python3-tox
+Requires: python3-pygraphviz
+Requires: python3-sphinx
+Requires: python3-sphinx-rtd-theme
+Requires: python3-black
+Requires: python3-check-manifest
+Requires: python3-flake8
+Requires: python3-flake8-black
+Requires: python3-flake8-bugbear
+Requires: python3-flake8-isort
+Requires: python3-isort
+Requires: python3-mypy
+Requires: python3-pep8-naming
+Requires: python3-types-requests
+Requires: python3-types-setuptools
+Requires: python3-pytest
+Requires: python3-pytest-cov
+Requires: python3-responses
+
+%description
+******
+Mopidy
+******
+
+`Mopidy`_ is an extensible music server written in Python.
+
+Mopidy plays music from local disk, Spotify, SoundCloud, Google Play Music, and
+more. You edit the playlist from any phone, tablet, or computer using a variety
+of MPD and web clients.
+
+**Stream music from the cloud**
+
+Vanilla Mopidy only plays music from files and radio streams. Through
+`extensions`_, Mopidy can play music from cloud services like Spotify,
+SoundCloud, and Google Play Music.
+With Mopidy's extension support, backends for new music sources can be easily
+added.
+
+**Mopidy is just a server**
+
+Mopidy is a Python application that runs in a terminal or in the background on
+Linux computers or Macs that have network connectivity and audio output.
+Out of the box, Mopidy is an HTTP server. If you install the `Mopidy-MPD`_
+extension, it becomes an MPD server too. Many additional frontends for
+controlling Mopidy are available as extensions.
+
+**Pick your favorite client**
+
+You and the people around you can all connect their favorite MPD or web client
+to the Mopidy server to search for music and manage the playlist together.
+With a browser or MPD client, which is available for all popular operating
+systems, you can control the music from any phone, tablet, or computer.
+
+**Mopidy on Raspberry Pi**
+
+The `Raspberry Pi`_ is an popular device to run Mopidy on, either using
+Raspbian, Ubuntu, or Arch Linux.
+Pimoroni recommends Mopidy for use with their `Pirate Audio`_ audio gear for
+Raspberry Pi.
+Mopidy is also a significant building block in the `Pi Musicbox`_ integrated
+audio jukebox system for Raspberry Pi.
+
+**Mopidy is hackable**
+
+Mopidy's extension support and Python, JSON-RPC, and JavaScript APIs make
+Mopidy a perfect base for your projects.
+In one hack, a Raspberry Pi was embedded in an old cassette player. The buttons
+and volume control are wired up with GPIO on the Raspberry Pi, and is used to
+control playback through a custom Mopidy extension. The cassettes have NFC tags
+used to select playlists from Spotify.
+
+.. _Mopidy: https://mopidy.com/
+.. _extensions: https://mopidy.com/ext/
+.. _Mopidy-MPD: https://mopidy.com/ext/mpd/
+.. _Raspberry Pi: https://www.raspberrypi.org/
+.. _Pirate Audio: https://shop.pimoroni.com/collections/pirate-audio
+.. _Pi Musicbox: https://www.pimusicbox.com/
+
+
+**Getting started**
+
+To get started with Mopidy, begin by reading the
+`installation docs <https://docs.mopidy.com/en/latest/installation/>`_.
+
+
+**Project resources**
+
+- `Documentation <https://docs.mopidy.com/>`_
+- `Discourse forum <https://discourse.mopidy.com/>`_
+- `Zulip chat <https://mopidy.zulipchat.com/>`_
+- `Source code <https://github.com/mopidy/mopidy>`_
+- `Issue tracker <https://github.com/mopidy/mopidy/issues>`_
+
+.. image:: https://img.shields.io/pypi/v/Mopidy.svg?style=flat
+ :target: https://pypi.python.org/pypi/Mopidy/
+ :alt: Latest PyPI version
+
+.. image:: https://img.shields.io/github/workflow/status/mopidy/mopidy/CI
+ :target: https://github.com/mopidy/mopidy/actions
+ :alt: CI build status
+
+.. image:: https://img.shields.io/readthedocs/mopidy.svg
+ :target: https://docs.mopidy.com/
+ :alt: Read the Docs build status
+
+.. image:: https://img.shields.io/codecov/c/github/mopidy/mopidy/develop.svg
+ :target: https://codecov.io/gh/mopidy/mopidy
+ :alt: Test coverage
+
+.. image:: https://img.shields.io/badge/chat-on%20zulip-brightgreen
+ :target: https://mopidy.zulipchat.com/
+ :alt: Chat on Zulip
+
+
+%package -n python3-Mopidy
+Summary: Mopidy is an extensible music server written in Python
+Provides: python-Mopidy
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-Mopidy
+******
+Mopidy
+******
+
+`Mopidy`_ is an extensible music server written in Python.
+
+Mopidy plays music from local disk, Spotify, SoundCloud, Google Play Music, and
+more. You edit the playlist from any phone, tablet, or computer using a variety
+of MPD and web clients.
+
+**Stream music from the cloud**
+
+Vanilla Mopidy only plays music from files and radio streams. Through
+`extensions`_, Mopidy can play music from cloud services like Spotify,
+SoundCloud, and Google Play Music.
+With Mopidy's extension support, backends for new music sources can be easily
+added.
+
+**Mopidy is just a server**
+
+Mopidy is a Python application that runs in a terminal or in the background on
+Linux computers or Macs that have network connectivity and audio output.
+Out of the box, Mopidy is an HTTP server. If you install the `Mopidy-MPD`_
+extension, it becomes an MPD server too. Many additional frontends for
+controlling Mopidy are available as extensions.
+
+**Pick your favorite client**
+
+You and the people around you can all connect their favorite MPD or web client
+to the Mopidy server to search for music and manage the playlist together.
+With a browser or MPD client, which is available for all popular operating
+systems, you can control the music from any phone, tablet, or computer.
+
+**Mopidy on Raspberry Pi**
+
+The `Raspberry Pi`_ is an popular device to run Mopidy on, either using
+Raspbian, Ubuntu, or Arch Linux.
+Pimoroni recommends Mopidy for use with their `Pirate Audio`_ audio gear for
+Raspberry Pi.
+Mopidy is also a significant building block in the `Pi Musicbox`_ integrated
+audio jukebox system for Raspberry Pi.
+
+**Mopidy is hackable**
+
+Mopidy's extension support and Python, JSON-RPC, and JavaScript APIs make
+Mopidy a perfect base for your projects.
+In one hack, a Raspberry Pi was embedded in an old cassette player. The buttons
+and volume control are wired up with GPIO on the Raspberry Pi, and is used to
+control playback through a custom Mopidy extension. The cassettes have NFC tags
+used to select playlists from Spotify.
+
+.. _Mopidy: https://mopidy.com/
+.. _extensions: https://mopidy.com/ext/
+.. _Mopidy-MPD: https://mopidy.com/ext/mpd/
+.. _Raspberry Pi: https://www.raspberrypi.org/
+.. _Pirate Audio: https://shop.pimoroni.com/collections/pirate-audio
+.. _Pi Musicbox: https://www.pimusicbox.com/
+
+
+**Getting started**
+
+To get started with Mopidy, begin by reading the
+`installation docs <https://docs.mopidy.com/en/latest/installation/>`_.
+
+
+**Project resources**
+
+- `Documentation <https://docs.mopidy.com/>`_
+- `Discourse forum <https://discourse.mopidy.com/>`_
+- `Zulip chat <https://mopidy.zulipchat.com/>`_
+- `Source code <https://github.com/mopidy/mopidy>`_
+- `Issue tracker <https://github.com/mopidy/mopidy/issues>`_
+
+.. image:: https://img.shields.io/pypi/v/Mopidy.svg?style=flat
+ :target: https://pypi.python.org/pypi/Mopidy/
+ :alt: Latest PyPI version
+
+.. image:: https://img.shields.io/github/workflow/status/mopidy/mopidy/CI
+ :target: https://github.com/mopidy/mopidy/actions
+ :alt: CI build status
+
+.. image:: https://img.shields.io/readthedocs/mopidy.svg
+ :target: https://docs.mopidy.com/
+ :alt: Read the Docs build status
+
+.. image:: https://img.shields.io/codecov/c/github/mopidy/mopidy/develop.svg
+ :target: https://codecov.io/gh/mopidy/mopidy
+ :alt: Test coverage
+
+.. image:: https://img.shields.io/badge/chat-on%20zulip-brightgreen
+ :target: https://mopidy.zulipchat.com/
+ :alt: Chat on Zulip
+
+
+%package help
+Summary: Development documents and examples for Mopidy
+Provides: python3-Mopidy-doc
+%description help
+******
+Mopidy
+******
+
+`Mopidy`_ is an extensible music server written in Python.
+
+Mopidy plays music from local disk, Spotify, SoundCloud, Google Play Music, and
+more. You edit the playlist from any phone, tablet, or computer using a variety
+of MPD and web clients.
+
+**Stream music from the cloud**
+
+Vanilla Mopidy only plays music from files and radio streams. Through
+`extensions`_, Mopidy can play music from cloud services like Spotify,
+SoundCloud, and Google Play Music.
+With Mopidy's extension support, backends for new music sources can be easily
+added.
+
+**Mopidy is just a server**
+
+Mopidy is a Python application that runs in a terminal or in the background on
+Linux computers or Macs that have network connectivity and audio output.
+Out of the box, Mopidy is an HTTP server. If you install the `Mopidy-MPD`_
+extension, it becomes an MPD server too. Many additional frontends for
+controlling Mopidy are available as extensions.
+
+**Pick your favorite client**
+
+You and the people around you can all connect their favorite MPD or web client
+to the Mopidy server to search for music and manage the playlist together.
+With a browser or MPD client, which is available for all popular operating
+systems, you can control the music from any phone, tablet, or computer.
+
+**Mopidy on Raspberry Pi**
+
+The `Raspberry Pi`_ is an popular device to run Mopidy on, either using
+Raspbian, Ubuntu, or Arch Linux.
+Pimoroni recommends Mopidy for use with their `Pirate Audio`_ audio gear for
+Raspberry Pi.
+Mopidy is also a significant building block in the `Pi Musicbox`_ integrated
+audio jukebox system for Raspberry Pi.
+
+**Mopidy is hackable**
+
+Mopidy's extension support and Python, JSON-RPC, and JavaScript APIs make
+Mopidy a perfect base for your projects.
+In one hack, a Raspberry Pi was embedded in an old cassette player. The buttons
+and volume control are wired up with GPIO on the Raspberry Pi, and is used to
+control playback through a custom Mopidy extension. The cassettes have NFC tags
+used to select playlists from Spotify.
+
+.. _Mopidy: https://mopidy.com/
+.. _extensions: https://mopidy.com/ext/
+.. _Mopidy-MPD: https://mopidy.com/ext/mpd/
+.. _Raspberry Pi: https://www.raspberrypi.org/
+.. _Pirate Audio: https://shop.pimoroni.com/collections/pirate-audio
+.. _Pi Musicbox: https://www.pimusicbox.com/
+
+
+**Getting started**
+
+To get started with Mopidy, begin by reading the
+`installation docs <https://docs.mopidy.com/en/latest/installation/>`_.
+
+
+**Project resources**
+
+- `Documentation <https://docs.mopidy.com/>`_
+- `Discourse forum <https://discourse.mopidy.com/>`_
+- `Zulip chat <https://mopidy.zulipchat.com/>`_
+- `Source code <https://github.com/mopidy/mopidy>`_
+- `Issue tracker <https://github.com/mopidy/mopidy/issues>`_
+
+.. image:: https://img.shields.io/pypi/v/Mopidy.svg?style=flat
+ :target: https://pypi.python.org/pypi/Mopidy/
+ :alt: Latest PyPI version
+
+.. image:: https://img.shields.io/github/workflow/status/mopidy/mopidy/CI
+ :target: https://github.com/mopidy/mopidy/actions
+ :alt: CI build status
+
+.. image:: https://img.shields.io/readthedocs/mopidy.svg
+ :target: https://docs.mopidy.com/
+ :alt: Read the Docs build status
+
+.. image:: https://img.shields.io/codecov/c/github/mopidy/mopidy/develop.svg
+ :target: https://codecov.io/gh/mopidy/mopidy
+ :alt: Test coverage
+
+.. image:: https://img.shields.io/badge/chat-on%20zulip-brightgreen
+ :target: https://mopidy.zulipchat.com/
+ :alt: Chat on Zulip
+
+
+%prep
+%autosetup -n Mopidy-3.4.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-Mopidy -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed Apr 12 2023 Python_Bot <Python_Bot@openeuler.org> - 3.4.1-1
+- Package Spec generated