summaryrefslogtreecommitdiff
path: root/python-mplfinance.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-mplfinance.spec')
-rw-r--r--python-mplfinance.spec74
1 files changed, 74 insertions, 0 deletions
diff --git a/python-mplfinance.spec b/python-mplfinance.spec
new file mode 100644
index 0000000..c8d7446
--- /dev/null
+++ b/python-mplfinance.spec
@@ -0,0 +1,74 @@
+%global _empty_manifest_terminate_build 0
+Name: python-mplfinance
+Version: 0.12.9b7
+Release: 1
+Summary: Utilities for the visualization, and visual analysis, of financial data
+License: BSD-style
+URL: http://github.com/matplotlib/mplfinance
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/df/4c/ccefe9e5a90a05a864d13b410b435f69f59984a728e28431cb421a305013/mplfinance-0.12.9b7.tar.gz
+BuildArch: noarch
+
+Requires: python3-matplotlib
+Requires: python3-pandas
+
+%description
+## <a name="announcements"></a>**&roarr; [Latest Release Information](https://github.com/matplotlib/mplfinance/releases) &loarr;**
+
+%package -n python3-mplfinance
+Summary: Utilities for the visualization, and visual analysis, of financial data
+Provides: python-mplfinance
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-mplfinance
+## <a name="announcements"></a>**&roarr; [Latest Release Information](https://github.com/matplotlib/mplfinance/releases) &loarr;**
+
+%package help
+Summary: Development documents and examples for mplfinance
+Provides: python3-mplfinance-doc
+%description help
+## <a name="announcements"></a>**&roarr; [Latest Release Information](https://github.com/matplotlib/mplfinance/releases) &loarr;**
+
+%prep
+%autosetup -n mplfinance-0.12.9b7
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-mplfinance -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 0.12.9b7-1
+- Package Spec generated