summaryrefslogtreecommitdiff
path: root/python-myria-cluster.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-myria-cluster.spec')
-rw-r--r--python-myria-cluster.spec108
1 files changed, 108 insertions, 0 deletions
diff --git a/python-myria-cluster.spec b/python-myria-cluster.spec
new file mode 100644
index 0000000..837a7cc
--- /dev/null
+++ b/python-myria-cluster.spec
@@ -0,0 +1,108 @@
+%global _empty_manifest_terminate_build 0
+Name: python-myria-cluster
+Version: 0.1.54
+Release: 1
+Summary: CLI to deploy the Myria parallel database on Amazon EC2
+License: BSD
+URL: https://github.com/uwescience/myria-ec2-ansible/tarball/0.1.54
+Source0: https://mirrors.aliyun.com/pypi/web/packages/1b/93/e2d09ffb563012405e18297f6e5b8e791c1fce480c767ed58aa5308cce1d/myria-cluster-0.1.54.tar.gz
+BuildArch: noarch
+
+
+%description
+# myria-ec2-ansible
+
+Python package for deploying Myria on Amazon EC2
+
+## How to set up a Myria cluster on EC2
+
+For local development, clone this repository, set up a virtual environment using `virtualenv`, and use the following command (run from the repository root directory) to install the package while allowing editing _in situ_:
+
+```
+pip install --upgrade --editable .
+```
+To deploy a Myria cluster using this package, or to install this package for non-development use, please refer to the [Myria Cloud Deployment](http://myria.cs.washington.edu/docs/myria-ec2.html) documentation.
+
+
+%package -n python3-myria-cluster
+Summary: CLI to deploy the Myria parallel database on Amazon EC2
+Provides: python-myria-cluster
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-myria-cluster
+# myria-ec2-ansible
+
+Python package for deploying Myria on Amazon EC2
+
+## How to set up a Myria cluster on EC2
+
+For local development, clone this repository, set up a virtual environment using `virtualenv`, and use the following command (run from the repository root directory) to install the package while allowing editing _in situ_:
+
+```
+pip install --upgrade --editable .
+```
+To deploy a Myria cluster using this package, or to install this package for non-development use, please refer to the [Myria Cloud Deployment](http://myria.cs.washington.edu/docs/myria-ec2.html) documentation.
+
+
+%package help
+Summary: Development documents and examples for myria-cluster
+Provides: python3-myria-cluster-doc
+%description help
+# myria-ec2-ansible
+
+Python package for deploying Myria on Amazon EC2
+
+## How to set up a Myria cluster on EC2
+
+For local development, clone this repository, set up a virtual environment using `virtualenv`, and use the following command (run from the repository root directory) to install the package while allowing editing _in situ_:
+
+```
+pip install --upgrade --editable .
+```
+To deploy a Myria cluster using this package, or to install this package for non-development use, please refer to the [Myria Cloud Deployment](http://myria.cs.washington.edu/docs/myria-ec2.html) documentation.
+
+
+%prep
+%autosetup -n myria-cluster-0.1.54
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-myria-cluster -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Jun 20 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.54-1
+- Package Spec generated