summaryrefslogtreecommitdiff
path: root/python-mysql-connector-repackaged.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-mysql-connector-repackaged.spec')
-rw-r--r--python-mysql-connector-repackaged.spec75
1 files changed, 75 insertions, 0 deletions
diff --git a/python-mysql-connector-repackaged.spec b/python-mysql-connector-repackaged.spec
new file mode 100644
index 0000000..fc303f5
--- /dev/null
+++ b/python-mysql-connector-repackaged.spec
@@ -0,0 +1,75 @@
+%global _empty_manifest_terminate_build 0
+Name: python-mysql-connector-repackaged
+Version: 0.3.1
+Release: 1
+Summary: MySQL driver written in Python
+License: GNU GPLv2 (with FOSS License Exception)
+URL: http://launchpad.net/myconnpy
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/00/c8/0f20b32691c3fe7dc013ca3971dac923b687c125c7e521f338e4a74ebef5/mysql-connector-repackaged-0.3.1.tar.gz
+BuildArch: noarch
+
+
+%description
+MySQL driver written in Python which does not depend on MySQL C client
+libraries and implements the DB API v2.0 specification (PEP-249).
+
+%package -n python3-mysql-connector-repackaged
+Summary: MySQL driver written in Python
+Provides: python-mysql-connector-repackaged
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-mysql-connector-repackaged
+MySQL driver written in Python which does not depend on MySQL C client
+libraries and implements the DB API v2.0 specification (PEP-249).
+
+%package help
+Summary: Development documents and examples for mysql-connector-repackaged
+Provides: python3-mysql-connector-repackaged-doc
+%description help
+MySQL driver written in Python which does not depend on MySQL C client
+libraries and implements the DB API v2.0 specification (PEP-249).
+
+%prep
+%autosetup -n mysql-connector-repackaged-0.3.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-mysql-connector-repackaged -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 0.3.1-1
+- Package Spec generated