summaryrefslogtreecommitdiff
path: root/python-mystran-validation.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-06-09 04:54:25 +0000
committerCoprDistGit <infra@openeuler.org>2023-06-09 04:54:25 +0000
commit0dd07b099388a08e2e3f38ecf5a7a62a388e1f9e (patch)
tree312bccbba140ac818403d0e8ac33959a95421d61 /python-mystran-validation.spec
parent92cfa9cd704beb101ea5a9f228a8c55a094107bd (diff)
automatic import of python-mystran-validationopeneuler20.03
Diffstat (limited to 'python-mystran-validation.spec')
-rw-r--r--python-mystran-validation.spec94
1 files changed, 94 insertions, 0 deletions
diff --git a/python-mystran-validation.spec b/python-mystran-validation.spec
new file mode 100644
index 0000000..06c2156
--- /dev/null
+++ b/python-mystran-validation.spec
@@ -0,0 +1,94 @@
+%global _empty_manifest_terminate_build 0
+Name: python-mystran-validation
+Version: 0.18.0
+Release: 1
+Summary: Python framework for MYSTRAN validation
+License: MIT license
+URL: https://pypi.org/project/mystran-validation/
+Source0: https://mirrors.aliyun.com/pypi/web/packages/59/eb/5f2f448733cf46a28d11535786655df197e6973d419bbea0cda7b77f91e1/mystran_validation-0.18.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-pytest
+Requires: python3-pytest-runner
+Requires: python3-pytest-xdist
+Requires: python3-appdirs
+Requires: python3-flake8
+Requires: python3-psutil
+Requires: python3-openpyxl
+Requires: python3-colorama
+Requires: python3-Click
+Requires: python3-pandas
+Requires: python3-pynastran
+Requires: python3-femap-neutral-parser
+Requires: python3-junit2html
+
+%description
+![pypi](https://img.shields.io/pypi/v/mystran_validation.svg "https://pypi.python.org/pypi/mystran_validation")
+Python framework for [MYSTRAN](http://https://github.com/dr-bill-c/MYSTRAN) validation.
+* Free software: MIT license
+[[_TOC_]]
+
+%package -n python3-mystran-validation
+Summary: Python framework for MYSTRAN validation
+Provides: python-mystran-validation
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-mystran-validation
+![pypi](https://img.shields.io/pypi/v/mystran_validation.svg "https://pypi.python.org/pypi/mystran_validation")
+Python framework for [MYSTRAN](http://https://github.com/dr-bill-c/MYSTRAN) validation.
+* Free software: MIT license
+[[_TOC_]]
+
+%package help
+Summary: Development documents and examples for mystran-validation
+Provides: python3-mystran-validation-doc
+%description help
+![pypi](https://img.shields.io/pypi/v/mystran_validation.svg "https://pypi.python.org/pypi/mystran_validation")
+Python framework for [MYSTRAN](http://https://github.com/dr-bill-c/MYSTRAN) validation.
+* Free software: MIT license
+[[_TOC_]]
+
+%prep
+%autosetup -n mystran_validation-0.18.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-mystran-validation -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri Jun 09 2023 Python_Bot <Python_Bot@openeuler.org> - 0.18.0-1
+- Package Spec generated