summaryrefslogtreecommitdiff
path: root/python-naas-drivers.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-naas-drivers.spec')
-rw-r--r--python-naas-drivers.spec219
1 files changed, 219 insertions, 0 deletions
diff --git a/python-naas-drivers.spec b/python-naas-drivers.spec
new file mode 100644
index 0000000..02ef76b
--- /dev/null
+++ b/python-naas-drivers.spec
@@ -0,0 +1,219 @@
+%global _empty_manifest_terminate_build 0
+Name: python-naas-drivers
+Version: 0.109.1
+Release: 1
+Summary: Drivers made to easy connect to any services
+License: BSD
+URL: https://github.com/jupyter-naas/drivers
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/20/5a/c6f186731cf2b8693215ebe32bb54f368451d62801bac3f0f789cd1ab79b/naas-drivers-0.109.1.tar.gz
+BuildArch: noarch
+
+
+%description
+![Bump version](https://github.com/jupyter-naas/drivers/workflows/Bump%20version/badge.svg)
+![GitHub license](https://img.shields.io/github/license/jupyter-naas/drivers)
+![Test Python package](https://github.com/jupyter-naas/drivers/workflows/Test%20Python%20package/badge.svg)
+![Upload Python Package](https://github.com/jupyter-naas/drivers/workflows/Upload%20Python%20Package/badge.svg)
+![codecov](https://codecov.io/gh/jupyter-naas/drivers/branch/master/graph/badge.svg?token=IUF0AKYEB0)
+![PRs Welcome](https://img.shields.io/badge/PRs-welcome-brightgreen.svg)
+[![Maintainability Rating](https://sonarcloud.io/api/project_badges/measure?project=jupyter-naas_drivers&metric=sqale_rating)](https://sonarcloud.io/dashboard?id=jupyter-naas_naas)
+<a href="#badge">
+ <img alt="semantic-release" src="https://img.shields.io/badge/%20%20%F0%9F%93%A6%F0%9F%9A%80-semantic--release-e10079.svg">
+</a>
+<a href="http://commitizen.github.io/cz-cli/"><img alt="Commitizen friendly" src="https://img.shields.io/badge/commitizen-friendly-brightgreen.svg"></a>
+![PyPI](https://img.shields.io/pypi/v/naas_drivers)
+
+# Welcome to Naas Drivers 🏎
+
+Simple formulas to build highly efficient scripts.<br>
+You can check the documentation here: https://docs.naas.ai
+
+## Low code philosophy
+
+We came from excel with the conviction that Python is awesome and much more powerful.
+But the number of lines you have to write in Python can be overwelming. <br>
+
+So we created simple low code formulas that tech and non-tech people can use to facilitate integrations with third party tools.<br>
+
+Simple formulas to interact with powerfull tools.<br>
+Each driver returns a dataframe to get a strandardized output accross integrations.
+
+## Issues
+If you found a bug or need a new feature, please raise an issue.
+
+## Install
+
+`python -m pip install naas_drivers`
+
+### Check lint
+
+`python3 -m black naas` format better <br>
+`python3 -m flake8 naas` check if any left error
+
+### Publish
+
+This auto publish on pypip by github action on main branch.
+
+### Authors:
+* [Jeremy Ravenel](https://github.com/jravenel)
+* [Maxime Jublou](https://github.com/Dr0p42)
+* [Martin Donadieu](https://github.com/riderx)
+* [Florent Ravenel](https://github.com/FlorentLvr)
+
+
+%package -n python3-naas-drivers
+Summary: Drivers made to easy connect to any services
+Provides: python-naas-drivers
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-naas-drivers
+![Bump version](https://github.com/jupyter-naas/drivers/workflows/Bump%20version/badge.svg)
+![GitHub license](https://img.shields.io/github/license/jupyter-naas/drivers)
+![Test Python package](https://github.com/jupyter-naas/drivers/workflows/Test%20Python%20package/badge.svg)
+![Upload Python Package](https://github.com/jupyter-naas/drivers/workflows/Upload%20Python%20Package/badge.svg)
+![codecov](https://codecov.io/gh/jupyter-naas/drivers/branch/master/graph/badge.svg?token=IUF0AKYEB0)
+![PRs Welcome](https://img.shields.io/badge/PRs-welcome-brightgreen.svg)
+[![Maintainability Rating](https://sonarcloud.io/api/project_badges/measure?project=jupyter-naas_drivers&metric=sqale_rating)](https://sonarcloud.io/dashboard?id=jupyter-naas_naas)
+<a href="#badge">
+ <img alt="semantic-release" src="https://img.shields.io/badge/%20%20%F0%9F%93%A6%F0%9F%9A%80-semantic--release-e10079.svg">
+</a>
+<a href="http://commitizen.github.io/cz-cli/"><img alt="Commitizen friendly" src="https://img.shields.io/badge/commitizen-friendly-brightgreen.svg"></a>
+![PyPI](https://img.shields.io/pypi/v/naas_drivers)
+
+# Welcome to Naas Drivers 🏎
+
+Simple formulas to build highly efficient scripts.<br>
+You can check the documentation here: https://docs.naas.ai
+
+## Low code philosophy
+
+We came from excel with the conviction that Python is awesome and much more powerful.
+But the number of lines you have to write in Python can be overwelming. <br>
+
+So we created simple low code formulas that tech and non-tech people can use to facilitate integrations with third party tools.<br>
+
+Simple formulas to interact with powerfull tools.<br>
+Each driver returns a dataframe to get a strandardized output accross integrations.
+
+## Issues
+If you found a bug or need a new feature, please raise an issue.
+
+## Install
+
+`python -m pip install naas_drivers`
+
+### Check lint
+
+`python3 -m black naas` format better <br>
+`python3 -m flake8 naas` check if any left error
+
+### Publish
+
+This auto publish on pypip by github action on main branch.
+
+### Authors:
+* [Jeremy Ravenel](https://github.com/jravenel)
+* [Maxime Jublou](https://github.com/Dr0p42)
+* [Martin Donadieu](https://github.com/riderx)
+* [Florent Ravenel](https://github.com/FlorentLvr)
+
+
+%package help
+Summary: Development documents and examples for naas-drivers
+Provides: python3-naas-drivers-doc
+%description help
+![Bump version](https://github.com/jupyter-naas/drivers/workflows/Bump%20version/badge.svg)
+![GitHub license](https://img.shields.io/github/license/jupyter-naas/drivers)
+![Test Python package](https://github.com/jupyter-naas/drivers/workflows/Test%20Python%20package/badge.svg)
+![Upload Python Package](https://github.com/jupyter-naas/drivers/workflows/Upload%20Python%20Package/badge.svg)
+![codecov](https://codecov.io/gh/jupyter-naas/drivers/branch/master/graph/badge.svg?token=IUF0AKYEB0)
+![PRs Welcome](https://img.shields.io/badge/PRs-welcome-brightgreen.svg)
+[![Maintainability Rating](https://sonarcloud.io/api/project_badges/measure?project=jupyter-naas_drivers&metric=sqale_rating)](https://sonarcloud.io/dashboard?id=jupyter-naas_naas)
+<a href="#badge">
+ <img alt="semantic-release" src="https://img.shields.io/badge/%20%20%F0%9F%93%A6%F0%9F%9A%80-semantic--release-e10079.svg">
+</a>
+<a href="http://commitizen.github.io/cz-cli/"><img alt="Commitizen friendly" src="https://img.shields.io/badge/commitizen-friendly-brightgreen.svg"></a>
+![PyPI](https://img.shields.io/pypi/v/naas_drivers)
+
+# Welcome to Naas Drivers 🏎
+
+Simple formulas to build highly efficient scripts.<br>
+You can check the documentation here: https://docs.naas.ai
+
+## Low code philosophy
+
+We came from excel with the conviction that Python is awesome and much more powerful.
+But the number of lines you have to write in Python can be overwelming. <br>
+
+So we created simple low code formulas that tech and non-tech people can use to facilitate integrations with third party tools.<br>
+
+Simple formulas to interact with powerfull tools.<br>
+Each driver returns a dataframe to get a strandardized output accross integrations.
+
+## Issues
+If you found a bug or need a new feature, please raise an issue.
+
+## Install
+
+`python -m pip install naas_drivers`
+
+### Check lint
+
+`python3 -m black naas` format better <br>
+`python3 -m flake8 naas` check if any left error
+
+### Publish
+
+This auto publish on pypip by github action on main branch.
+
+### Authors:
+* [Jeremy Ravenel](https://github.com/jravenel)
+* [Maxime Jublou](https://github.com/Dr0p42)
+* [Martin Donadieu](https://github.com/riderx)
+* [Florent Ravenel](https://github.com/FlorentLvr)
+
+
+%prep
+%autosetup -n naas-drivers-0.109.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-naas-drivers -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed Apr 12 2023 Python_Bot <Python_Bot@openeuler.org> - 0.109.1-1
+- Package Spec generated