summaryrefslogtreecommitdiff
path: root/python-nailgun.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-15 08:27:23 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-15 08:27:23 +0000
commit926fe306b419afe1e4b864f88c906f6fdc892482 (patch)
tree0e8ff86f1516680ace58341d8674ab735ca90f99 /python-nailgun.spec
parent673e079c260b4d99a91d1a600b008ac44888be22 (diff)
automatic import of python-nailgun
Diffstat (limited to 'python-nailgun.spec')
-rw-r--r--python-nailgun.spec93
1 files changed, 93 insertions, 0 deletions
diff --git a/python-nailgun.spec b/python-nailgun.spec
new file mode 100644
index 0000000..91430a0
--- /dev/null
+++ b/python-nailgun.spec
@@ -0,0 +1,93 @@
+%global _empty_manifest_terminate_build 0
+Name: python-nailgun
+Version: 0.32.0
+Release: 1
+Summary: A library that facilitates easy usage of the Satellite 6 API
+License: GPLv3
+URL: https://github.com/SatelliteQE/nailgun
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/be/55/21b92737123a5c89252b1d17d9b6d0956e18226cf55f226feccb5feedbe3/nailgun-0.32.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-inflection
+Requires: python3-packaging
+Requires: python3-pyxdg
+Requires: python3-requests
+Requires: python3-blinker-herald
+Requires: python3-fauxfactory
+
+%description
+NailGun is a GPL-licensed Python library that facilitates easy usage of the
+Satellite 6 API.
+The `full documentation <http://nailgun.readthedocs.io/en/latest/>`_ is
+available on ReadTheDocs. It can also be generated locally::
+ pip install -r requirements.txt -r requirements-dev.txt
+ make docs-html
+
+%package -n python3-nailgun
+Summary: A library that facilitates easy usage of the Satellite 6 API
+Provides: python-nailgun
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-nailgun
+NailGun is a GPL-licensed Python library that facilitates easy usage of the
+Satellite 6 API.
+The `full documentation <http://nailgun.readthedocs.io/en/latest/>`_ is
+available on ReadTheDocs. It can also be generated locally::
+ pip install -r requirements.txt -r requirements-dev.txt
+ make docs-html
+
+%package help
+Summary: Development documents and examples for nailgun
+Provides: python3-nailgun-doc
+%description help
+NailGun is a GPL-licensed Python library that facilitates easy usage of the
+Satellite 6 API.
+The `full documentation <http://nailgun.readthedocs.io/en/latest/>`_ is
+available on ReadTheDocs. It can also be generated locally::
+ pip install -r requirements.txt -r requirements-dev.txt
+ make docs-html
+
+%prep
+%autosetup -n nailgun-0.32.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-nailgun -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon May 15 2023 Python_Bot <Python_Bot@openeuler.org> - 0.32.0-1
+- Package Spec generated