summaryrefslogtreecommitdiff
path: root/python-neat-python.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-15 04:35:24 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-15 04:35:24 +0000
commit6892fe8005614ddcc17fef889e2e5f185c12cf8d (patch)
tree16ec57816b93b51d03208a1cea88355fa4f9bb62 /python-neat-python.spec
parent91c392c13cf87698ee24d98fc62e87de211707dd (diff)
automatic import of python-neat-python
Diffstat (limited to 'python-neat-python.spec')
-rw-r--r--python-neat-python.spec81
1 files changed, 81 insertions, 0 deletions
diff --git a/python-neat-python.spec b/python-neat-python.spec
new file mode 100644
index 0000000..b8518d9
--- /dev/null
+++ b/python-neat-python.spec
@@ -0,0 +1,81 @@
+%global _empty_manifest_terminate_build 0
+Name: python-neat-python
+Version: 0.92
+Release: 1
+Summary: A NEAT (NeuroEvolution of Augmenting Topologies) implementation
+License: BSD
+URL: https://github.com/CodeReclaimers/neat-python
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/f6/92/2778744d408304b77eb39c1edf91eaced1e18e1cd45a766a20fd1b716c22/neat-python-0.92.tar.gz
+BuildArch: noarch
+
+
+%description
+Python implementation of NEAT (NeuroEvolution of Augmenting Topologies), a method developed by Kenneth O. Stanley for evolving arbitrary neural networks.
+
+
+
+
+%package -n python3-neat-python
+Summary: A NEAT (NeuroEvolution of Augmenting Topologies) implementation
+Provides: python-neat-python
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-neat-python
+Python implementation of NEAT (NeuroEvolution of Augmenting Topologies), a method developed by Kenneth O. Stanley for evolving arbitrary neural networks.
+
+
+
+
+%package help
+Summary: Development documents and examples for neat-python
+Provides: python3-neat-python-doc
+%description help
+Python implementation of NEAT (NeuroEvolution of Augmenting Topologies), a method developed by Kenneth O. Stanley for evolving arbitrary neural networks.
+
+
+
+
+%prep
+%autosetup -n neat-python-0.92
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-neat-python -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon May 15 2023 Python_Bot <Python_Bot@openeuler.org> - 0.92-1
+- Package Spec generated