summaryrefslogtreecommitdiff
path: root/python-netaddr.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-netaddr.spec')
-rw-r--r--python-netaddr.spec132
1 files changed, 132 insertions, 0 deletions
diff --git a/python-netaddr.spec b/python-netaddr.spec
new file mode 100644
index 0000000..9ce4a3b
--- /dev/null
+++ b/python-netaddr.spec
@@ -0,0 +1,132 @@
+%global _empty_manifest_terminate_build 0
+Name: python-netaddr
+Version: 0.8.0
+Release: 1
+Summary: A network address manipulation library for Python
+License: BSD License
+URL: https://github.com/drkjam/netaddr/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/c3/3b/fe5bda7a3e927d9008c897cf1a0858a9ba9924a6b4750ec1824c9e617587/netaddr-0.8.0.tar.gz
+BuildArch: noarch
+
+
+%description
+A system-independent network address manipulation library for Python 2.7 and 3.5+.
+(Python 2.7 and 3.5 support is deprecated).
+Provides support for:
+Layer 3 addresses
+- IPv4 and IPv6 addresses, subnets, masks, prefixes
+- iterating, slicing, sorting, summarizing and classifying IP networks
+- dealing with various ranges formats (CIDR, arbitrary ranges and
+ globs, nmap)
+- set based operations (unions, intersections etc) over IP addresses
+ and subnets
+- parsing a large variety of different formats and notations
+- looking up IANA IP block information
+- generating DNS reverse lookups
+- supernetting and subnetting
+Layer 2 addresses
+- representation and manipulation MAC addresses and EUI-64 identifiers
+- looking up IEEE organisational information (OUI, IAB)
+- generating derived IPv6 addresses
+Starting with Python 3.3 there's an `ipaddress <https://docs.python.org/3/library/ipaddress.html>`_
+module in the Python standard library which provides layer 3 address manipulation
+capabilities overlapping ``netaddr``.
+
+%package -n python3-netaddr
+Summary: A network address manipulation library for Python
+Provides: python-netaddr
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-netaddr
+A system-independent network address manipulation library for Python 2.7 and 3.5+.
+(Python 2.7 and 3.5 support is deprecated).
+Provides support for:
+Layer 3 addresses
+- IPv4 and IPv6 addresses, subnets, masks, prefixes
+- iterating, slicing, sorting, summarizing and classifying IP networks
+- dealing with various ranges formats (CIDR, arbitrary ranges and
+ globs, nmap)
+- set based operations (unions, intersections etc) over IP addresses
+ and subnets
+- parsing a large variety of different formats and notations
+- looking up IANA IP block information
+- generating DNS reverse lookups
+- supernetting and subnetting
+Layer 2 addresses
+- representation and manipulation MAC addresses and EUI-64 identifiers
+- looking up IEEE organisational information (OUI, IAB)
+- generating derived IPv6 addresses
+Starting with Python 3.3 there's an `ipaddress <https://docs.python.org/3/library/ipaddress.html>`_
+module in the Python standard library which provides layer 3 address manipulation
+capabilities overlapping ``netaddr``.
+
+%package help
+Summary: Development documents and examples for netaddr
+Provides: python3-netaddr-doc
+%description help
+A system-independent network address manipulation library for Python 2.7 and 3.5+.
+(Python 2.7 and 3.5 support is deprecated).
+Provides support for:
+Layer 3 addresses
+- IPv4 and IPv6 addresses, subnets, masks, prefixes
+- iterating, slicing, sorting, summarizing and classifying IP networks
+- dealing with various ranges formats (CIDR, arbitrary ranges and
+ globs, nmap)
+- set based operations (unions, intersections etc) over IP addresses
+ and subnets
+- parsing a large variety of different formats and notations
+- looking up IANA IP block information
+- generating DNS reverse lookups
+- supernetting and subnetting
+Layer 2 addresses
+- representation and manipulation MAC addresses and EUI-64 identifiers
+- looking up IEEE organisational information (OUI, IAB)
+- generating derived IPv6 addresses
+Starting with Python 3.3 there's an `ipaddress <https://docs.python.org/3/library/ipaddress.html>`_
+module in the Python standard library which provides layer 3 address manipulation
+capabilities overlapping ``netaddr``.
+
+%prep
+%autosetup -n netaddr-0.8.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-netaddr -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 0.8.0-1
+- Package Spec generated