summaryrefslogtreecommitdiff
path: root/python-neuroboom.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-neuroboom.spec')
-rw-r--r--python-neuroboom.spec88
1 files changed, 88 insertions, 0 deletions
diff --git a/python-neuroboom.spec b/python-neuroboom.spec
new file mode 100644
index 0000000..8169794
--- /dev/null
+++ b/python-neuroboom.spec
@@ -0,0 +1,88 @@
+%global _empty_manifest_terminate_build 0
+Name: python-neuroboom
+Version: 0.3.55
+Release: 1
+Summary: A suite of python tools for visualisation and analysis of Connectomic data
+License: BSD (3-clause)
+URL: https://github.com/markuspleijzier/neuroboom
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/37/75/7b3844e91803607e38cc838c853c0d0b86f232a500293cdedc978d65bb0c/neuroboom-0.3.55.tar.gz
+BuildArch: noarch
+
+Requires: python3-IPython
+Requires: python3-navis
+Requires: python3-matplotlib
+Requires: python3-numpy
+Requires: python3-networkx
+Requires: python3-plotly
+Requires: python3-pandas
+Requires: python3-catmaid
+Requires: python3-phate
+Requires: python3-seaborn
+Requires: python3-sklearn
+Requires: python3-scprep
+Requires: python3-scipy
+Requires: python3-tqdm
+Requires: python3-cloud-volume
+Requires: python3-fafbseg
+
+%description
+
+
+%package -n python3-neuroboom
+Summary: A suite of python tools for visualisation and analysis of Connectomic data
+Provides: python-neuroboom
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-neuroboom
+
+
+%package help
+Summary: Development documents and examples for neuroboom
+Provides: python3-neuroboom-doc
+%description help
+
+
+%prep
+%autosetup -n neuroboom-0.3.55
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-neuroboom -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 0.3.55-1
+- Package Spec generated