summaryrefslogtreecommitdiff
path: root/python-nodewire.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-06-20 09:52:57 +0000
committerCoprDistGit <infra@openeuler.org>2023-06-20 09:52:57 +0000
commite9e774d5c52548d80b301107f96e1a012e0016e4 (patch)
tree13383aa3946ecc950b27a11e811686977c7953dd /python-nodewire.spec
parent4ce39d6cd0e22511ac0b125b4a09ccff58bdb0cd (diff)
automatic import of python-nodewireopeneuler20.03
Diffstat (limited to 'python-nodewire.spec')
-rw-r--r--python-nodewire.spec84
1 files changed, 84 insertions, 0 deletions
diff --git a/python-nodewire.spec b/python-nodewire.spec
new file mode 100644
index 0000000..e236718
--- /dev/null
+++ b/python-nodewire.spec
@@ -0,0 +1,84 @@
+%global _empty_manifest_terminate_build 0
+Name: python-nodewire
+Version: 2.0.2
+Release: 1
+Summary: Nodewire
+License: BSD
+URL: http://www.nodewire.org
+Source0: https://mirrors.aliyun.com/pypi/web/packages/ae/b9/5674358a6bd0cd00ef95504387419cf90b76e9dc6537e055953cc130cc56/nodewire-2.0.2.tar.gz
+BuildArch: noarch
+
+
+%description
+This package enables you to:
+1. Create software that connects to IoT devices for monitoring and control
+2. Create microservices
+NodeWire uses a dataflow programming model. Nodes have input and output ports through which it receives and sends messages.
+A NodeWire program can connect to other nodes to monitor and send messagesto it.
+
+%package -n python3-nodewire
+Summary: Nodewire
+Provides: python-nodewire
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-nodewire
+This package enables you to:
+1. Create software that connects to IoT devices for monitoring and control
+2. Create microservices
+NodeWire uses a dataflow programming model. Nodes have input and output ports through which it receives and sends messages.
+A NodeWire program can connect to other nodes to monitor and send messagesto it.
+
+%package help
+Summary: Development documents and examples for nodewire
+Provides: python3-nodewire-doc
+%description help
+This package enables you to:
+1. Create software that connects to IoT devices for monitoring and control
+2. Create microservices
+NodeWire uses a dataflow programming model. Nodes have input and output ports through which it receives and sends messages.
+A NodeWire program can connect to other nodes to monitor and send messagesto it.
+
+%prep
+%autosetup -n nodewire-2.0.2
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-nodewire -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Jun 20 2023 Python_Bot <Python_Bot@openeuler.org> - 2.0.2-1
+- Package Spec generated