summaryrefslogtreecommitdiff
path: root/python-nslookup.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-12 03:39:08 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-12 03:39:08 +0000
commitb9cc2cf841cad82c246e2561f506553c76a8811d (patch)
tree34326db00da2b1d092b28dff1f699c6b823e3e47 /python-nslookup.spec
parent93fe2ca8a91815e4a65d7fbaaf75f7beddb31e35 (diff)
automatic import of python-nslookup
Diffstat (limited to 'python-nslookup.spec')
-rw-r--r--python-nslookup.spec217
1 files changed, 217 insertions, 0 deletions
diff --git a/python-nslookup.spec b/python-nslookup.spec
new file mode 100644
index 0000000..7af3ff8
--- /dev/null
+++ b/python-nslookup.spec
@@ -0,0 +1,217 @@
+%global _empty_manifest_terminate_build 0
+Name: python-nslookup
+Version: 1.7.0
+Release: 1
+Summary: Sensible high-level DNS lookups in Python, using DNSpython resolver
+License: Mozilla Public License 2.0 (MPL 2.0)
+URL: https://github.com/wesinator/pynslookup
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/32/45/ef8e10cb885407fe4572f5079e1165286acfc6cd0fbe71fadf85ec40a7a2/nslookup-1.7.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-dnspython
+
+%description
+# PyNslookup
+[![PyPi package](https://img.shields.io/pypi/v/nslookup.svg)](https://pypi.python.org/pypi/nslookup)
+
+Simple, sensible high-level DNS lookups in Python (on top of dnspython dns.resolver).
+
+#### Purpose and scope
+This library is a simple wrapper around [dnspython](https://github.com/rthalley/dnspython),
+to provide high level functions with good error/exception handling, for the most common basic DNS lookup cases.
+
+- `A`, `AAAA` record lookups (typical DNS queries)
+- SOA lookups
+
+This is not intended to be a complete wrapper around dnspython library or to handle uncommon edge cases.
+Features like DoH are out of scope, and should be done using other libraries or dnspython directly.
+
+### Usage
+
+Returns an object containing two arrays:
+ - `response_full`: the full DNS response string(s)
+ - `answer`: the parsed DNS answer (list of IPs or SOA string)
+
+```python
+from nslookup import Nslookup
+
+domain = "example.com"
+
+# Initialize Nslookup
+dns_query = Nslookup()
+# Alternatively, the Nslookup constructor supports optional
+# arguments for setting custom dns servers (defaults to system DNS),
+# verbosity (default: True) and using TCP instead of UDP (default: False)
+dns_query = Nslookup(dns_servers=["1.1.1.1"], verbose=False, tcp=False)
+
+ips_record = dns_query.dns_lookup(domain)
+print(ips_record.response_full, ips_record.answer)
+
+soa_record = dns_query.soa_lookup(domain)
+print(soa_record.response_full, soa_record.answer)
+```
+
+### Note
+This library is oriented around regular UDP DNS.
+
+Using TCP modes in this simple library will create a separate TCP session for
+each query, which can be resource intensive for a large number of queries.
+For this it is recommended to use the more granular `dnspython` API directly.
+
+
+
+
+%package -n python3-nslookup
+Summary: Sensible high-level DNS lookups in Python, using DNSpython resolver
+Provides: python-nslookup
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-nslookup
+# PyNslookup
+[![PyPi package](https://img.shields.io/pypi/v/nslookup.svg)](https://pypi.python.org/pypi/nslookup)
+
+Simple, sensible high-level DNS lookups in Python (on top of dnspython dns.resolver).
+
+#### Purpose and scope
+This library is a simple wrapper around [dnspython](https://github.com/rthalley/dnspython),
+to provide high level functions with good error/exception handling, for the most common basic DNS lookup cases.
+
+- `A`, `AAAA` record lookups (typical DNS queries)
+- SOA lookups
+
+This is not intended to be a complete wrapper around dnspython library or to handle uncommon edge cases.
+Features like DoH are out of scope, and should be done using other libraries or dnspython directly.
+
+### Usage
+
+Returns an object containing two arrays:
+ - `response_full`: the full DNS response string(s)
+ - `answer`: the parsed DNS answer (list of IPs or SOA string)
+
+```python
+from nslookup import Nslookup
+
+domain = "example.com"
+
+# Initialize Nslookup
+dns_query = Nslookup()
+# Alternatively, the Nslookup constructor supports optional
+# arguments for setting custom dns servers (defaults to system DNS),
+# verbosity (default: True) and using TCP instead of UDP (default: False)
+dns_query = Nslookup(dns_servers=["1.1.1.1"], verbose=False, tcp=False)
+
+ips_record = dns_query.dns_lookup(domain)
+print(ips_record.response_full, ips_record.answer)
+
+soa_record = dns_query.soa_lookup(domain)
+print(soa_record.response_full, soa_record.answer)
+```
+
+### Note
+This library is oriented around regular UDP DNS.
+
+Using TCP modes in this simple library will create a separate TCP session for
+each query, which can be resource intensive for a large number of queries.
+For this it is recommended to use the more granular `dnspython` API directly.
+
+
+
+
+%package help
+Summary: Development documents and examples for nslookup
+Provides: python3-nslookup-doc
+%description help
+# PyNslookup
+[![PyPi package](https://img.shields.io/pypi/v/nslookup.svg)](https://pypi.python.org/pypi/nslookup)
+
+Simple, sensible high-level DNS lookups in Python (on top of dnspython dns.resolver).
+
+#### Purpose and scope
+This library is a simple wrapper around [dnspython](https://github.com/rthalley/dnspython),
+to provide high level functions with good error/exception handling, for the most common basic DNS lookup cases.
+
+- `A`, `AAAA` record lookups (typical DNS queries)
+- SOA lookups
+
+This is not intended to be a complete wrapper around dnspython library or to handle uncommon edge cases.
+Features like DoH are out of scope, and should be done using other libraries or dnspython directly.
+
+### Usage
+
+Returns an object containing two arrays:
+ - `response_full`: the full DNS response string(s)
+ - `answer`: the parsed DNS answer (list of IPs or SOA string)
+
+```python
+from nslookup import Nslookup
+
+domain = "example.com"
+
+# Initialize Nslookup
+dns_query = Nslookup()
+# Alternatively, the Nslookup constructor supports optional
+# arguments for setting custom dns servers (defaults to system DNS),
+# verbosity (default: True) and using TCP instead of UDP (default: False)
+dns_query = Nslookup(dns_servers=["1.1.1.1"], verbose=False, tcp=False)
+
+ips_record = dns_query.dns_lookup(domain)
+print(ips_record.response_full, ips_record.answer)
+
+soa_record = dns_query.soa_lookup(domain)
+print(soa_record.response_full, soa_record.answer)
+```
+
+### Note
+This library is oriented around regular UDP DNS.
+
+Using TCP modes in this simple library will create a separate TCP session for
+each query, which can be resource intensive for a large number of queries.
+For this it is recommended to use the more granular `dnspython` API directly.
+
+
+
+
+%prep
+%autosetup -n nslookup-1.7.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-nslookup -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed Apr 12 2023 Python_Bot <Python_Bot@openeuler.org> - 1.7.0-1
+- Package Spec generated