summaryrefslogtreecommitdiff
path: root/python-numpy-groupies.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-numpy-groupies.spec')
-rw-r--r--python-numpy-groupies.spec110
1 files changed, 110 insertions, 0 deletions
diff --git a/python-numpy-groupies.spec b/python-numpy-groupies.spec
new file mode 100644
index 0000000..adf05fc
--- /dev/null
+++ b/python-numpy-groupies.spec
@@ -0,0 +1,110 @@
+%global _empty_manifest_terminate_build 0
+Name: python-numpy-groupies
+Version: 0.9.20
+Release: 1
+Summary: Optimised tools for group-indexing operations: aggregated sum and more.
+License: BSD
+URL: https://github.com/ml31415/numpy-groupies
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/9d/b7/859669e07c37a6217b795dbae8bc580c03e13296a22e85d6f1fc7da5be00/numpy_groupies-0.9.20.tar.gz
+BuildArch: noarch
+
+Requires: python3-numpy
+Requires: python3-pytest
+
+%description
+
+This package consists of a couple of optimised tools for doing things that can roughly be
+considered "group-indexing operations". The most prominent tool is `aggregate`.
+
+`aggregate` takes an array of values, and an array giving the group number for each of those
+values. It then returns the sum (or mean, or std, or any, ...etc.) of the values in each group.
+You have probably come across this idea before, using `matlab` accumarray, `pandas` groupby,
+or generally MapReduce algorithms and histograms.
+
+There are different implementations of `aggregate` provided, based on plain `numpy`, `numba`
+and `weave`. Performance is a main concern, and so far we comfortably beat similar
+implementations in other packages (check the benchmarks).
+
+
+%package -n python3-numpy-groupies
+Summary: Optimised tools for group-indexing operations: aggregated sum and more.
+Provides: python-numpy-groupies
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-numpy-groupies
+
+This package consists of a couple of optimised tools for doing things that can roughly be
+considered "group-indexing operations". The most prominent tool is `aggregate`.
+
+`aggregate` takes an array of values, and an array giving the group number for each of those
+values. It then returns the sum (or mean, or std, or any, ...etc.) of the values in each group.
+You have probably come across this idea before, using `matlab` accumarray, `pandas` groupby,
+or generally MapReduce algorithms and histograms.
+
+There are different implementations of `aggregate` provided, based on plain `numpy`, `numba`
+and `weave`. Performance is a main concern, and so far we comfortably beat similar
+implementations in other packages (check the benchmarks).
+
+
+%package help
+Summary: Development documents and examples for numpy-groupies
+Provides: python3-numpy-groupies-doc
+%description help
+
+This package consists of a couple of optimised tools for doing things that can roughly be
+considered "group-indexing operations". The most prominent tool is `aggregate`.
+
+`aggregate` takes an array of values, and an array giving the group number for each of those
+values. It then returns the sum (or mean, or std, or any, ...etc.) of the values in each group.
+You have probably come across this idea before, using `matlab` accumarray, `pandas` groupby,
+or generally MapReduce algorithms and histograms.
+
+There are different implementations of `aggregate` provided, based on plain `numpy`, `numba`
+and `weave`. Performance is a main concern, and so far we comfortably beat similar
+implementations in other packages (check the benchmarks).
+
+
+%prep
+%autosetup -n numpy-groupies-0.9.20
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-numpy-groupies -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed Apr 12 2023 Python_Bot <Python_Bot@openeuler.org> - 0.9.20-1
+- Package Spec generated