summaryrefslogtreecommitdiff
path: root/python-nuxeo.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-29 11:53:16 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-29 11:53:16 +0000
commitf99c7d8fb9fcd80c54e66210d92225e43beaad64 (patch)
treeea6b380ef5947810517d2959787ea07706ec24a4 /python-nuxeo.spec
parentb68972243a9f57e0a980d1bc1646ef876407818e (diff)
automatic import of python-nuxeo
Diffstat (limited to 'python-nuxeo.spec')
-rw-r--r--python-nuxeo.spec85
1 files changed, 85 insertions, 0 deletions
diff --git a/python-nuxeo.spec b/python-nuxeo.spec
new file mode 100644
index 0000000..37c6b88
--- /dev/null
+++ b/python-nuxeo.spec
@@ -0,0 +1,85 @@
+%global _empty_manifest_terminate_build 0
+Name: python-nuxeo
+Version: 6.1.0
+Release: 1
+Summary: Nuxeo REST API Python client
+License: Apache Software
+URL: https://github.com/nuxeo/nuxeo-python-client
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/07/2b/9c84e116b8b3d1da16e39358a84a859c6110713be1004ceb04c6c3f527bf/nuxeo-6.1.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-requests
+Requires: python3-authlib
+Requires: python3-jwt
+Requires: python3-boto3
+
+%description
+|Build Status| |Quality| |Coverage|
+The Nuxeo Python Client is a Python client library for the Nuxeo
+Automation and REST API. It works with Python 3.6+.
+This is an ongoing project, supported by Nuxeo.
+
+%package -n python3-nuxeo
+Summary: Nuxeo REST API Python client
+Provides: python-nuxeo
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-nuxeo
+|Build Status| |Quality| |Coverage|
+The Nuxeo Python Client is a Python client library for the Nuxeo
+Automation and REST API. It works with Python 3.6+.
+This is an ongoing project, supported by Nuxeo.
+
+%package help
+Summary: Development documents and examples for nuxeo
+Provides: python3-nuxeo-doc
+%description help
+|Build Status| |Quality| |Coverage|
+The Nuxeo Python Client is a Python client library for the Nuxeo
+Automation and REST API. It works with Python 3.6+.
+This is an ongoing project, supported by Nuxeo.
+
+%prep
+%autosetup -n nuxeo-6.1.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-nuxeo -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon May 29 2023 Python_Bot <Python_Bot@openeuler.org> - 6.1.0-1
+- Package Spec generated