summaryrefslogtreecommitdiff
path: root/python-od.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-11 03:04:03 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-11 03:04:03 +0000
commit01cd3d882c5164eaf3d075c38d581ec2591df728 (patch)
tree68d57c64485e7979f0f691af2a9f75462a6766c3 /python-od.spec
parent7cfaf48b0d1a71c548c2d0a560856e400e1979b5 (diff)
automatic import of python-od
Diffstat (limited to 'python-od.spec')
-rw-r--r--python-od.spec175
1 files changed, 175 insertions, 0 deletions
diff --git a/python-od.spec b/python-od.spec
new file mode 100644
index 0000000..b4e7396
--- /dev/null
+++ b/python-od.spec
@@ -0,0 +1,175 @@
+%global _empty_manifest_terminate_build 0
+Name: python-od
+Version: 2.0.2
+Release: 1
+Summary: Shorthand syntax for building OrderedDicts
+License: MIT
+URL: https://github.com/epsy/od
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/31/65/86e6a714f93a0b497cb0ec0a2ee6580179c568969525c7e87b783749e89d/od-2.0.2.tar.gz
+BuildArch: noarch
+
+Requires: python3-repeated-test
+
+%description
+od
+==
+
+.. image:: https://github.com/epsy/od/actions/workflows/ci.yml/badge.svg?branch=master
+ :target: https://github.com/epsy/od/actions/workflows/ci.yml
+
+.. image:: https://coveralls.io/repos/github/epsy/od/badge.svg?branch=master
+ :target: https://coveralls.io/github/epsy/od?branch=master
+
+
+The ``od`` package adds a shorthand syntax to create instances of `OrderedDict
+<https://docs.python.org/3/library/collections.html#collections.OrderedDict>`_
+::
+
+ >>> import od
+ >>>
+ >>> od["cat": "fish", "mouse": "cheese"]
+ OrderedDict([('cat', 'fish'), ('mouse', 'cheese')])
+ >>> od["mouse": "cheese", "cat": "fish"]
+ OrderedDict([('mouse', 'cheese'), ('cat', 'fish')])
+
+You can also use it like the regular constructor for ``OrderedDict``::
+
+ >>> od()
+ OrderedDict()
+ >>> an_iterable = [("cat", "fish"), ("mouse", "cheese")]
+ >>> od(an_iterable)
+ OrderedDict([('cat', 'fish'), ('mouse', 'cheese')])
+
+Install this package using `pip <https://pip.pypa.io/en/stable/installing/>`_::
+
+ $ pip install --user od
+
+
+
+
+%package -n python3-od
+Summary: Shorthand syntax for building OrderedDicts
+Provides: python-od
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-od
+od
+==
+
+.. image:: https://github.com/epsy/od/actions/workflows/ci.yml/badge.svg?branch=master
+ :target: https://github.com/epsy/od/actions/workflows/ci.yml
+
+.. image:: https://coveralls.io/repos/github/epsy/od/badge.svg?branch=master
+ :target: https://coveralls.io/github/epsy/od?branch=master
+
+
+The ``od`` package adds a shorthand syntax to create instances of `OrderedDict
+<https://docs.python.org/3/library/collections.html#collections.OrderedDict>`_
+::
+
+ >>> import od
+ >>>
+ >>> od["cat": "fish", "mouse": "cheese"]
+ OrderedDict([('cat', 'fish'), ('mouse', 'cheese')])
+ >>> od["mouse": "cheese", "cat": "fish"]
+ OrderedDict([('mouse', 'cheese'), ('cat', 'fish')])
+
+You can also use it like the regular constructor for ``OrderedDict``::
+
+ >>> od()
+ OrderedDict()
+ >>> an_iterable = [("cat", "fish"), ("mouse", "cheese")]
+ >>> od(an_iterable)
+ OrderedDict([('cat', 'fish'), ('mouse', 'cheese')])
+
+Install this package using `pip <https://pip.pypa.io/en/stable/installing/>`_::
+
+ $ pip install --user od
+
+
+
+
+%package help
+Summary: Development documents and examples for od
+Provides: python3-od-doc
+%description help
+od
+==
+
+.. image:: https://github.com/epsy/od/actions/workflows/ci.yml/badge.svg?branch=master
+ :target: https://github.com/epsy/od/actions/workflows/ci.yml
+
+.. image:: https://coveralls.io/repos/github/epsy/od/badge.svg?branch=master
+ :target: https://coveralls.io/github/epsy/od?branch=master
+
+
+The ``od`` package adds a shorthand syntax to create instances of `OrderedDict
+<https://docs.python.org/3/library/collections.html#collections.OrderedDict>`_
+::
+
+ >>> import od
+ >>>
+ >>> od["cat": "fish", "mouse": "cheese"]
+ OrderedDict([('cat', 'fish'), ('mouse', 'cheese')])
+ >>> od["mouse": "cheese", "cat": "fish"]
+ OrderedDict([('mouse', 'cheese'), ('cat', 'fish')])
+
+You can also use it like the regular constructor for ``OrderedDict``::
+
+ >>> od()
+ OrderedDict()
+ >>> an_iterable = [("cat", "fish"), ("mouse", "cheese")]
+ >>> od(an_iterable)
+ OrderedDict([('cat', 'fish'), ('mouse', 'cheese')])
+
+Install this package using `pip <https://pip.pypa.io/en/stable/installing/>`_::
+
+ $ pip install --user od
+
+
+
+
+%prep
+%autosetup -n od-2.0.2
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-od -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 2.0.2-1
+- Package Spec generated