summaryrefslogtreecommitdiff
path: root/python-omz-theme-ignore.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-omz-theme-ignore.spec')
-rw-r--r--python-omz-theme-ignore.spec111
1 files changed, 111 insertions, 0 deletions
diff --git a/python-omz-theme-ignore.spec b/python-omz-theme-ignore.spec
new file mode 100644
index 0000000..20bcd83
--- /dev/null
+++ b/python-omz-theme-ignore.spec
@@ -0,0 +1,111 @@
+%global _empty_manifest_terminate_build 0
+Name: python-omz-theme-ignore
+Version: 0.1.3
+Release: 1
+Summary: Easy add current random theme to ZSH_THEME_RANDOM_IGNORED section in .zshrc file.
+License: MIT
+URL: https://github.com/paterit/omz_ignore_theme
+Source0: https://mirrors.aliyun.com/pypi/web/packages/2c/c5/bb5a53a3da98d3a00f88609782abf46f6b73d7afe0eb46d69c849e7761c2/omz_theme_ignore-0.1.3.tar.gz
+BuildArch: noarch
+
+
+%description
+[![Python application](https://github.com/paterit/omz_theme_ignore_py/actions/workflows/python-app.yml/badge.svg)](https://github.com/paterit/omz_theme_ignore_py/actions/workflows/python-app.yml)
+
+# omz_theme_ignore_py
+
+Add current RANDOM_THEME from [oh-my-zsh](https://ohmyz.sh) to the .zshrc file to the ZSH_RANDOM_IGNORE_THEME section. Use as a zsh alias via python script:
+
+`alias it="python3 omz_theme_ignore/main.py $RANDOM_THEME"`
+
+or via package:
+
+`python3 -m pip install omz_theme_ignore`
+
+`alias it="omz_theme_ignore $RANDOM_THEME"`
+
+
+%package -n python3-omz-theme-ignore
+Summary: Easy add current random theme to ZSH_THEME_RANDOM_IGNORED section in .zshrc file.
+Provides: python-omz-theme-ignore
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-omz-theme-ignore
+[![Python application](https://github.com/paterit/omz_theme_ignore_py/actions/workflows/python-app.yml/badge.svg)](https://github.com/paterit/omz_theme_ignore_py/actions/workflows/python-app.yml)
+
+# omz_theme_ignore_py
+
+Add current RANDOM_THEME from [oh-my-zsh](https://ohmyz.sh) to the .zshrc file to the ZSH_RANDOM_IGNORE_THEME section. Use as a zsh alias via python script:
+
+`alias it="python3 omz_theme_ignore/main.py $RANDOM_THEME"`
+
+or via package:
+
+`python3 -m pip install omz_theme_ignore`
+
+`alias it="omz_theme_ignore $RANDOM_THEME"`
+
+
+%package help
+Summary: Development documents and examples for omz-theme-ignore
+Provides: python3-omz-theme-ignore-doc
+%description help
+[![Python application](https://github.com/paterit/omz_theme_ignore_py/actions/workflows/python-app.yml/badge.svg)](https://github.com/paterit/omz_theme_ignore_py/actions/workflows/python-app.yml)
+
+# omz_theme_ignore_py
+
+Add current RANDOM_THEME from [oh-my-zsh](https://ohmyz.sh) to the .zshrc file to the ZSH_RANDOM_IGNORE_THEME section. Use as a zsh alias via python script:
+
+`alias it="python3 omz_theme_ignore/main.py $RANDOM_THEME"`
+
+or via package:
+
+`python3 -m pip install omz_theme_ignore`
+
+`alias it="omz_theme_ignore $RANDOM_THEME"`
+
+
+%prep
+%autosetup -n omz_theme_ignore-0.1.3
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-omz-theme-ignore -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Jun 20 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.3-1
+- Package Spec generated