summaryrefslogtreecommitdiff
path: root/python-opencensus-extension-azure-functions.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-opencensus-extension-azure-functions.spec')
-rw-r--r--python-opencensus-extension-azure-functions.spec74
1 files changed, 74 insertions, 0 deletions
diff --git a/python-opencensus-extension-azure-functions.spec b/python-opencensus-extension-azure-functions.spec
new file mode 100644
index 0000000..2749710
--- /dev/null
+++ b/python-opencensus-extension-azure-functions.spec
@@ -0,0 +1,74 @@
+%global _empty_manifest_terminate_build 0
+Name: python-opencensus-extension-azure-functions
+Version: 1.0.0
+Release: 1
+Summary: OpenCensus extension for Azure Functions
+License: Apache-2.0
+URL: https://github.com/census-ecosystem/opencensus-python-extensions-azure
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/b6/69/388dc77bd4535d51019ef26a815b4c3c76eda806eaa334d52a45461c4e37/opencensus-extension-azure-functions-1.0.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-azure-functions
+Requires: python3-opencensus-ext-azure
+
+%description
+|pypi|
+
+%package -n python3-opencensus-extension-azure-functions
+Summary: OpenCensus extension for Azure Functions
+Provides: python-opencensus-extension-azure-functions
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-opencensus-extension-azure-functions
+|pypi|
+
+%package help
+Summary: Development documents and examples for opencensus-extension-azure-functions
+Provides: python3-opencensus-extension-azure-functions-doc
+%description help
+|pypi|
+
+%prep
+%autosetup -n opencensus-extension-azure-functions-1.0.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-opencensus-extension-azure-functions -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Thu May 18 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.0-1
+- Package Spec generated