summaryrefslogtreecommitdiff
path: root/python-opensitua-http.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-opensitua-http.spec')
-rw-r--r--python-opensitua-http.spec81
1 files changed, 81 insertions, 0 deletions
diff --git a/python-opensitua-http.spec b/python-opensitua-http.spec
new file mode 100644
index 0000000..09a0a8a
--- /dev/null
+++ b/python-opensitua-http.spec
@@ -0,0 +1,81 @@
+%global _empty_manifest_terminate_build 0
+Name: python-opensitua-http
+Version: 0.0.72
+Release: 1
+Summary: A core functions package
+License: MIT License
+URL: https://github.com/valluzzi/opensitua_http.git
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/ee/f0/dd4ca1b378a880b32cd486da7effb9b281c703ebd62870f83d2d364df616/opensitua_http-0.0.72.tar.gz
+BuildArch: noarch
+
+Requires: python3-jinja2
+Requires: python3-six
+Requires: python3-opensitua-core
+
+%description
+A core functions package
+
+
+
+%package -n python3-opensitua-http
+Summary: A core functions package
+Provides: python-opensitua-http
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-opensitua-http
+A core functions package
+
+
+
+%package help
+Summary: Development documents and examples for opensitua-http
+Provides: python3-opensitua-http-doc
+%description help
+A core functions package
+
+
+
+%prep
+%autosetup -n opensitua-http-0.0.72
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-opensitua-http -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Thu May 18 2023 Python_Bot <Python_Bot@openeuler.org> - 0.0.72-1
+- Package Spec generated