summaryrefslogtreecommitdiff
path: root/python-orange-spectroscopy.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-orange-spectroscopy.spec')
-rw-r--r--python-orange-spectroscopy.spec102
1 files changed, 102 insertions, 0 deletions
diff --git a/python-orange-spectroscopy.spec b/python-orange-spectroscopy.spec
new file mode 100644
index 0000000..55d6eb2
--- /dev/null
+++ b/python-orange-spectroscopy.spec
@@ -0,0 +1,102 @@
+%global _empty_manifest_terminate_build 0
+Name: python-Orange-Spectroscopy
+Version: 0.6.9
+Release: 1
+Summary: Extends Orange to handle spectral and hyperspectral analysis.
+License: GPLv3+
+URL: https://github.com/Quasars/orange-spectroscopy
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/10/bc/8bed752f56f8399aa097953392bd89445ec0953d901c6cb142966f40122f/Orange-Spectroscopy-0.6.9.tar.gz
+BuildArch: noarch
+
+Requires: python3-AnyQt
+Requires: python3-Orange3
+Requires: python3-bottleneck
+Requires: python3-colorcet
+Requires: python3-extranormal3
+Requires: python3-h5py
+Requires: python3-lmfit
+Requires: python3-numpy
+Requires: python3-orange-canvas-core
+Requires: python3-orange-widget-base
+Requires: python3-pebble
+Requires: python3-pillow
+Requires: python3-pip
+Requires: python3-pyqtgraph
+Requires: python3-renishawWiRE
+Requires: python3-scikit-learn
+Requires: python3-scipy
+Requires: python3-serverfiles
+Requires: python3-setuptools
+Requires: python3-spectral
+Requires: python3-coverage
+
+%description
+Orange add-on for spectral data analysis. Provides spectra and
+hyperspectra plotting, interpolation, preprocessing (cutting, smoothing,
+normalization), and integration. Supports common spectral file formats.
+See [documentation](https://orange-spectroscopy.readthedocs.io/).
+
+%package -n python3-Orange-Spectroscopy
+Summary: Extends Orange to handle spectral and hyperspectral analysis.
+Provides: python-Orange-Spectroscopy
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-Orange-Spectroscopy
+Orange add-on for spectral data analysis. Provides spectra and
+hyperspectra plotting, interpolation, preprocessing (cutting, smoothing,
+normalization), and integration. Supports common spectral file formats.
+See [documentation](https://orange-spectroscopy.readthedocs.io/).
+
+%package help
+Summary: Development documents and examples for Orange-Spectroscopy
+Provides: python3-Orange-Spectroscopy-doc
+%description help
+Orange add-on for spectral data analysis. Provides spectra and
+hyperspectra plotting, interpolation, preprocessing (cutting, smoothing,
+normalization), and integration. Supports common spectral file formats.
+See [documentation](https://orange-spectroscopy.readthedocs.io/).
+
+%prep
+%autosetup -n Orange-Spectroscopy-0.6.9
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-Orange-Spectroscopy -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 0.6.9-1
+- Package Spec generated