summaryrefslogtreecommitdiff
path: root/python-orange3-timeseries.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-15 06:47:57 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-15 06:47:57 +0000
commitbd7dd4568b7c4b7c603ac99cd4cd6a884bf4d726 (patch)
treebb45edc14a087b35d831d11953234170627a6196 /python-orange3-timeseries.spec
parente4d1fcf69a86385c404aa7c4f2dbf6b5a21a8bc9 (diff)
automatic import of python-orange3-timeseries
Diffstat (limited to 'python-orange3-timeseries.spec')
-rw-r--r--python-orange3-timeseries.spec94
1 files changed, 94 insertions, 0 deletions
diff --git a/python-orange3-timeseries.spec b/python-orange3-timeseries.spec
new file mode 100644
index 0000000..37cc635
--- /dev/null
+++ b/python-orange3-timeseries.spec
@@ -0,0 +1,94 @@
+%global _empty_manifest_terminate_build 0
+Name: python-Orange3-Timeseries
+Version: 0.5.3
+Release: 1
+Summary: Orange3 add-on for exploring time series and sequential data.
+License: GPLv3+
+URL: https://github.com/biolab/orange3-timeseries
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/79/53/0fcf4da63080b519c0cac924af0b2332fdee0791ba7d1b1b7f23219557be/Orange3-Timeseries-0.5.3.tar.gz
+BuildArch: noarch
+
+Requires: python3-Orange3
+Requires: python3-statsmodels
+Requires: python3-dateutil
+Requires: python3-pandas
+Requires: python3-pandas-datareader
+Requires: python3-numpy
+Requires: python3-scipy
+Requires: python3-more-itertools
+Requires: python3-pyqtgraph
+Requires: python3-sphinx
+Requires: python3-recommonmark
+Requires: python3-sphinx-rtd-theme
+Requires: python3-coverage
+
+%description
+Orange add-on for analyzing, visualizing, manipulating, and forecasting time
+series data. The add-on includes ARIMA and VAR models, model evaluation, time
+series preprocessing, seasonal adjustment and a wide array of visualizations.
+See [documentation](http://orange3-timeseries.readthedocs.org/).
+
+%package -n python3-Orange3-Timeseries
+Summary: Orange3 add-on for exploring time series and sequential data.
+Provides: python-Orange3-Timeseries
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-Orange3-Timeseries
+Orange add-on for analyzing, visualizing, manipulating, and forecasting time
+series data. The add-on includes ARIMA and VAR models, model evaluation, time
+series preprocessing, seasonal adjustment and a wide array of visualizations.
+See [documentation](http://orange3-timeseries.readthedocs.org/).
+
+%package help
+Summary: Development documents and examples for Orange3-Timeseries
+Provides: python3-Orange3-Timeseries-doc
+%description help
+Orange add-on for analyzing, visualizing, manipulating, and forecasting time
+series data. The add-on includes ARIMA and VAR models, model evaluation, time
+series preprocessing, seasonal adjustment and a wide array of visualizations.
+See [documentation](http://orange3-timeseries.readthedocs.org/).
+
+%prep
+%autosetup -n Orange3-Timeseries-0.5.3
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-Orange3-Timeseries -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon May 15 2023 Python_Bot <Python_Bot@openeuler.org> - 0.5.3-1
+- Package Spec generated