summaryrefslogtreecommitdiff
path: root/python-outcome-devkit.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-outcome-devkit.spec')
-rw-r--r--python-outcome-devkit.spec144
1 files changed, 144 insertions, 0 deletions
diff --git a/python-outcome-devkit.spec b/python-outcome-devkit.spec
new file mode 100644
index 0000000..dbdac71
--- /dev/null
+++ b/python-outcome-devkit.spec
@@ -0,0 +1,144 @@
+%global _empty_manifest_terminate_build 0
+Name: python-outcome-devkit
+Version: 7.2.0
+Release: 1
+Summary: A package containing common dev dependencies for python projects.
+License: ISC
+URL: https://github.com/outcome-co/devkit-py
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/6f/16/dcd9c98606fc03ede3fe26b7cd9a11f4cba8b7abab8ed1af47949b71a1bb/outcome-devkit-7.2.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-flake8-builtins
+Requires: python3-flake8-commas
+Requires: python3-flake8-mutable
+Requires: python3-flake8-print
+Requires: python3-wemake-python-styleguide
+Requires: python3-flake8-pytest
+Requires: python3-flake8-breakpoint
+Requires: python3-flake8-if-expr
+Requires: python3-flake8-return
+Requires: python3-flake8-colors
+Requires: python3-flake8
+Requires: python3-black
+Requires: python3-coverage
+Requires: python3-pytest
+Requires: python3-pdbpp
+Requires: python3-ipython
+Requires: python3-isort
+Requires: python3-pytest-asyncio
+Requires: python3-outcome-utils
+Requires: python3-pactman
+Requires: python3-outcome-read-toml
+Requires: python3-magicinvoke
+Requires: python3-colored-traceback
+Requires: python3-pre-commit
+Requires: python3-outcome-stubs
+Requires: python3-rich
+Requires: python3-pydantic
+Requires: python3-poetry
+Requires: python3-syrupy
+Requires: python3-pygit2
+
+%description
+# devkit-py
+![Continuous Integration](https://github.com/outcome-co/devkit-py/workflows/Continuous%20Integration/badge.svg) ![version-badge](https://img.shields.io/badge/version-7.2.0-brightgreen)
+
+A package containing common dev dependencies for python projects.
+
+## Usage
+
+```sh
+poetry add -D outcome-devkit
+```
+
+## Development
+
+Run `./bootstrap.sh` when you clone the repository to get set up.
+
+
+%package -n python3-outcome-devkit
+Summary: A package containing common dev dependencies for python projects.
+Provides: python-outcome-devkit
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-outcome-devkit
+# devkit-py
+![Continuous Integration](https://github.com/outcome-co/devkit-py/workflows/Continuous%20Integration/badge.svg) ![version-badge](https://img.shields.io/badge/version-7.2.0-brightgreen)
+
+A package containing common dev dependencies for python projects.
+
+## Usage
+
+```sh
+poetry add -D outcome-devkit
+```
+
+## Development
+
+Run `./bootstrap.sh` when you clone the repository to get set up.
+
+
+%package help
+Summary: Development documents and examples for outcome-devkit
+Provides: python3-outcome-devkit-doc
+%description help
+# devkit-py
+![Continuous Integration](https://github.com/outcome-co/devkit-py/workflows/Continuous%20Integration/badge.svg) ![version-badge](https://img.shields.io/badge/version-7.2.0-brightgreen)
+
+A package containing common dev dependencies for python projects.
+
+## Usage
+
+```sh
+poetry add -D outcome-devkit
+```
+
+## Development
+
+Run `./bootstrap.sh` when you clone the repository to get set up.
+
+
+%prep
+%autosetup -n outcome-devkit-7.2.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-outcome-devkit -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 7.2.0-1
+- Package Spec generated