summaryrefslogtreecommitdiff
path: root/python-ovs.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-ovs.spec')
-rw-r--r--python-ovs.spec74
1 files changed, 74 insertions, 0 deletions
diff --git a/python-ovs.spec b/python-ovs.spec
new file mode 100644
index 0000000..abb5d98
--- /dev/null
+++ b/python-ovs.spec
@@ -0,0 +1,74 @@
+%global _empty_manifest_terminate_build 0
+Name: python-ovs
+Version: 2.17.1.post1
+Release: 1
+Summary: Open vSwitch library
+License: Apache 2.0
+URL: http://www.openvswitch.org/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/4c/88/e7effd0c8d50e08d99c91d366b8ebdf493daac9fd96bc834165c3a58b7c3/ovs-2.17.1.post1.tar.gz
+BuildArch: noarch
+
+Requires: python3-sortedcontainers
+Requires: python3-pywin32
+
+%description
+
+
+%package -n python3-ovs
+Summary: Open vSwitch library
+Provides: python-ovs
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-ovs
+
+
+%package help
+Summary: Development documents and examples for ovs
+Provides: python3-ovs-doc
+%description help
+
+
+%prep
+%autosetup -n ovs-2.17.1.post1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-ovs -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 2.17.1.post1-1
+- Package Spec generated