summaryrefslogtreecommitdiff
path: root/python-oxdna-analysis-tools.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-oxdna-analysis-tools.spec')
-rw-r--r--python-oxdna-analysis-tools.spec16
1 files changed, 8 insertions, 8 deletions
diff --git a/python-oxdna-analysis-tools.spec b/python-oxdna-analysis-tools.spec
index 1533ce8..d874879 100644
--- a/python-oxdna-analysis-tools.spec
+++ b/python-oxdna-analysis-tools.spec
@@ -5,7 +5,7 @@ Release: 1
Summary: Python scripts and libraries for structural analysis of oxDNA simulations.
License: GNU General Public License v3 (GPLv3)
URL: https://github.com/sulcgroup/oxdna_analysis_tools
-Source0: https://mirrors.nju.edu.cn/pypi/web/packages/ec/87/0ca423a5c8229bc22b04bb715c4836ad5a9529ce760444aeedfc47867980/oxDNA_analysis_tools-2.0.3.tar.gz
+Source0: https://mirrors.aliyun.com/pypi/web/packages/ec/87/0ca423a5c8229bc22b04bb715c4836ad5a9529ce760444aeedfc47867980/oxDNA_analysis_tools-2.0.3.tar.gz
BuildArch: noarch
Requires: python3-numpy
@@ -62,7 +62,7 @@ So for example, if you would like to use the file reader, you would include the
`from oxDNA_analysis_tools.UTILS.RyeReader import describe, get_confs`
%prep
-%autosetup -n oxDNA-analysis-tools-2.0.3
+%autosetup -n oxDNA_analysis_tools-2.0.3
%build
%py3_build
@@ -76,20 +76,20 @@ if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
- find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
- find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
- find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
- find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
- find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
@@ -102,5 +102,5 @@ mv %{buildroot}/doclist.lst .
%{_docdir}/*
%changelog
-* Tue May 30 2023 Python_Bot <Python_Bot@openeuler.org> - 2.0.3-1
+* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 2.0.3-1
- Package Spec generated