summaryrefslogtreecommitdiff
path: root/python-pagermaid.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-pagermaid.spec')
-rw-r--r--python-pagermaid.spec158
1 files changed, 158 insertions, 0 deletions
diff --git a/python-pagermaid.spec b/python-pagermaid.spec
new file mode 100644
index 0000000..c7dceeb
--- /dev/null
+++ b/python-pagermaid.spec
@@ -0,0 +1,158 @@
+%global _empty_manifest_terminate_build 0
+Name: python-pagermaid
+Version: 2020.2.post13
+Release: 1
+Summary: A telegram utility daemon and plugin framework.
+License: GNU General Public License v3 or later (GPLv3+)
+URL: https://katonkeyboard.moe/pagermaid.html
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/cb/04/484e5e85fb2dfe764eb412bbdabc811f766ba39f7960ed3d9b7038ec6953/pagermaid-2020.2.post13.tar.gz
+BuildArch: noarch
+
+Requires: python3-psutil
+Requires: python3-pyqrcode
+Requires: python3-pypng
+Requires: python3-pyzbar
+Requires: python3-emoji
+Requires: python3-youtube-dl
+Requires: python3-pyyaml
+Requires: python3-redis
+Requires: python3-coloredlogs
+Requires: python3-requests
+Requires: python3-pytz
+Requires: python3-cowpy
+Requires: python3-googletrans
+Requires: python3-beautifulsoup4
+Requires: python3-gtts
+Requires: python3-gtts-token
+Requires: python3-wordcloud
+Requires: python3-telethon
+Requires: python3-pillow
+Requires: python3-magic
+Requires: python3-pygments
+Requires: python3-distutils2-py3
+Requires: python3-speedtest-cli
+Requires: python3-gitpython
+Requires: python3-werkzeug
+Requires: python3-flask
+Requires: python3-flask-sqlalchemy
+Requires: python3-flask-login
+Requires: python3-flask-bcrypt
+Requires: python3-flask-wtf
+Requires: python3-wtforms
+Requires: python3-cheroot
+
+%description
+# PagerMaid
+
+PagerMaid is a utility daemon for telegram.
+
+It automates a range of tasks by responding to commands issued to self.
+
+Update channel: https://t.me/PagerMaid
+
+## Installation
+See [INSTALL.md](https://git.stykers.moe/users/stykers/repos/pagermaid/browse/INSTALL.md)
+
+## Contact
+Use -contact <message> on telegram, and enter the PM that's opened, if you have installation problems email me at stykers@stykers.moe or message me on telegram at [@KatOnKeyboard](https://t.me/KatOnKeyboard).
+
+
+## Special Thanks
+[Amine Oversoul](https://bitbucket.org/oversoul/pagermaid-ui)
+
+
+
+%package -n python3-pagermaid
+Summary: A telegram utility daemon and plugin framework.
+Provides: python-pagermaid
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-pagermaid
+# PagerMaid
+
+PagerMaid is a utility daemon for telegram.
+
+It automates a range of tasks by responding to commands issued to self.
+
+Update channel: https://t.me/PagerMaid
+
+## Installation
+See [INSTALL.md](https://git.stykers.moe/users/stykers/repos/pagermaid/browse/INSTALL.md)
+
+## Contact
+Use -contact <message> on telegram, and enter the PM that's opened, if you have installation problems email me at stykers@stykers.moe or message me on telegram at [@KatOnKeyboard](https://t.me/KatOnKeyboard).
+
+
+## Special Thanks
+[Amine Oversoul](https://bitbucket.org/oversoul/pagermaid-ui)
+
+
+
+%package help
+Summary: Development documents and examples for pagermaid
+Provides: python3-pagermaid-doc
+%description help
+# PagerMaid
+
+PagerMaid is a utility daemon for telegram.
+
+It automates a range of tasks by responding to commands issued to self.
+
+Update channel: https://t.me/PagerMaid
+
+## Installation
+See [INSTALL.md](https://git.stykers.moe/users/stykers/repos/pagermaid/browse/INSTALL.md)
+
+## Contact
+Use -contact <message> on telegram, and enter the PM that's opened, if you have installation problems email me at stykers@stykers.moe or message me on telegram at [@KatOnKeyboard](https://t.me/KatOnKeyboard).
+
+
+## Special Thanks
+[Amine Oversoul](https://bitbucket.org/oversoul/pagermaid-ui)
+
+
+
+%prep
+%autosetup -n pagermaid-2020.2.post13
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-pagermaid -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon May 29 2023 Python_Bot <Python_Bot@openeuler.org> - 2020.2.post13-1
+- Package Spec generated