summaryrefslogtreecommitdiff
path: root/python-pastel.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-pastel.spec')
-rw-r--r--python-pastel.spec84
1 files changed, 84 insertions, 0 deletions
diff --git a/python-pastel.spec b/python-pastel.spec
new file mode 100644
index 0000000..add9779
--- /dev/null
+++ b/python-pastel.spec
@@ -0,0 +1,84 @@
+%global _empty_manifest_terminate_build 0
+Name: python-pastel
+Version: 0.2.1
+Release: 1
+Summary: Bring colors to your terminal.
+License: MIT
+URL: https://github.com/sdispater/pastel
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/76/f1/4594f5e0fcddb6953e5b8fe00da8c317b8b41b547e2b3ae2da7512943c62/pastel-0.2.1.tar.gz
+BuildArch: noarch
+
+
+%description
+* Use predefined styles or add you own.
+* Disable colors all together by calling ``with_colors(False)``.
+* Automatically disables colors if the output is not a TTY.
+* Used in `cleo <https://github.com/sdispater/cleo>`_.
+* Supports Python **2.7+**, **3.5+** and **PyPy**.
+
+%package -n python3-pastel
+Summary: Bring colors to your terminal.
+Provides: python-pastel
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-pastel
+* Use predefined styles or add you own.
+* Disable colors all together by calling ``with_colors(False)``.
+* Automatically disables colors if the output is not a TTY.
+* Used in `cleo <https://github.com/sdispater/cleo>`_.
+* Supports Python **2.7+**, **3.5+** and **PyPy**.
+
+%package help
+Summary: Development documents and examples for pastel
+Provides: python3-pastel-doc
+%description help
+* Use predefined styles or add you own.
+* Disable colors all together by calling ``with_colors(False)``.
+* Automatically disables colors if the output is not a TTY.
+* Used in `cleo <https://github.com/sdispater/cleo>`_.
+* Supports Python **2.7+**, **3.5+** and **PyPy**.
+
+%prep
+%autosetup -n pastel-0.2.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-pastel -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Thu Mar 09 2023 Python_Bot <Python_Bot@openeuler.org> - 0.2.1-1
+- Package Spec generated