summaryrefslogtreecommitdiff
path: root/python-pbiapi.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-pbiapi.spec')
-rw-r--r--python-pbiapi.spec73
1 files changed, 73 insertions, 0 deletions
diff --git a/python-pbiapi.spec b/python-pbiapi.spec
new file mode 100644
index 0000000..f9bd327
--- /dev/null
+++ b/python-pbiapi.spec
@@ -0,0 +1,73 @@
+%global _empty_manifest_terminate_build 0
+Name: python-pbiapi
+Version: 0.2.2
+Release: 1
+Summary: A Python library for working with the Power BI API
+License: MIT License
+URL: https://github.com/scottmelhop/PowerBI-API-Python
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/70/83/74b2c68408795ed05ad70f4d6a8a059a293f058f45d28cabada9bc8373b3/pbiapi-0.2.2.tar.gz
+BuildArch: noarch
+
+Requires: python3-requests
+
+%description
+
+
+%package -n python3-pbiapi
+Summary: A Python library for working with the Power BI API
+Provides: python-pbiapi
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-pbiapi
+
+
+%package help
+Summary: Development documents and examples for pbiapi
+Provides: python3-pbiapi-doc
+%description help
+
+
+%prep
+%autosetup -n pbiapi-0.2.2
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-pbiapi -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 0.2.2-1
+- Package Spec generated