summaryrefslogtreecommitdiff
path: root/python-pbxproj.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-05 06:19:22 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-05 06:19:22 +0000
commit4a4f776ddc31afffba32eb9cd2e35ba14b3a0ae8 (patch)
treea2046a8f2aa4655cb51ab5dac0d06a5d7a087569 /python-pbxproj.spec
parent5b0f914915f7f970e2c63f63ecf92af5e50a3748 (diff)
automatic import of python-pbxprojopeneuler20.03
Diffstat (limited to 'python-pbxproj.spec')
-rw-r--r--python-pbxproj.spec74
1 files changed, 74 insertions, 0 deletions
diff --git a/python-pbxproj.spec b/python-pbxproj.spec
new file mode 100644
index 0000000..7d72d3c
--- /dev/null
+++ b/python-pbxproj.spec
@@ -0,0 +1,74 @@
+%global _empty_manifest_terminate_build 0
+Name: python-pbxproj
+Version: 3.5.0
+Release: 1
+Summary: XCode Project manipulation library for Python
+License: MIT License
+URL: http://github.com/kronenthaler/mod-pbxproj
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/ea/10/086488a06f1fe6849804511062356eeb34fd2cc856be102ddd132d51f562/pbxproj-3.5.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-openstep-parser
+Requires: python3-docopt
+
+%description
+This module can read, modify, and write a .pbxproj file from an Xcode 4+ projects. The file is usually called project.pbxproj and can be found inside the .xcodeproj bundle. Because some task cannot be done by clicking on an UI or opening Xcode to do it for you, this python module lets you automate the modification process.
+
+%package -n python3-pbxproj
+Summary: XCode Project manipulation library for Python
+Provides: python-pbxproj
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-pbxproj
+This module can read, modify, and write a .pbxproj file from an Xcode 4+ projects. The file is usually called project.pbxproj and can be found inside the .xcodeproj bundle. Because some task cannot be done by clicking on an UI or opening Xcode to do it for you, this python module lets you automate the modification process.
+
+%package help
+Summary: Development documents and examples for pbxproj
+Provides: python3-pbxproj-doc
+%description help
+This module can read, modify, and write a .pbxproj file from an Xcode 4+ projects. The file is usually called project.pbxproj and can be found inside the .xcodeproj bundle. Because some task cannot be done by clicking on an UI or opening Xcode to do it for you, this python module lets you automate the modification process.
+
+%prep
+%autosetup -n pbxproj-3.5.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-pbxproj -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 3.5.0-1
+- Package Spec generated