summaryrefslogtreecommitdiff
path: root/python-pdoc3.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-10 15:13:55 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-10 15:13:55 +0000
commit5c8b9a56e38e6397aac5960c670bad0b8bcdef2d (patch)
treefcf6aacbc73c403d2cf75bd8ea219c9bfae9c442 /python-pdoc3.spec
parentdd62e2c03968df32834b4edb9bf63be2d8b4b6a3 (diff)
automatic import of python-pdoc3
Diffstat (limited to 'python-pdoc3.spec')
-rw-r--r--python-pdoc3.spec96
1 files changed, 96 insertions, 0 deletions
diff --git a/python-pdoc3.spec b/python-pdoc3.spec
new file mode 100644
index 0000000..1e4ba7f
--- /dev/null
+++ b/python-pdoc3.spec
@@ -0,0 +1,96 @@
+%global _empty_manifest_terminate_build 0
+Name: python-pdoc3
+Version: 0.10.0
+Release: 1
+Summary: Auto-generate API documentation for Python projects.
+License: AGPL-3.0
+URL: https://pdoc3.github.io/pdoc/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/95/be/69267c988fb7236cd60c452a4e7fb9a7991729476db490b634a07e7dfcdf/pdoc3-0.10.0.tar.gz
+BuildArch: noarch
+
+
+%description
+[![Build Status](https://img.shields.io/github/workflow/status/pdoc3/pdoc/CI?style=for-the-badge)](https://github.com/pdoc3/pdoc/actions)
+[![Code Coverage](https://img.shields.io/codecov/c/gh/pdoc3/pdoc.svg?style=for-the-badge)](https://codecov.io/gh/pdoc3/pdoc)
+[![pdoc3 on PyPI](https://img.shields.io/pypi/v/pdoc3.svg?color=blue&style=for-the-badge)](https://pypi.org/project/pdoc3)
+[![package downloads](https://img.shields.io/pypi/dm/pdoc3.svg?color=skyblue&style=for-the-badge)](https://pypi.org/project/pdoc3)
+[![GitHub Sponsors](https://img.shields.io/github/sponsors/kernc?color=pink&style=for-the-badge)](https://github.com/sponsors/kernc)
+Auto-generate API documentation for Python projects.
+[**Project website**](https://pdoc3.github.io/pdoc/)
+[Documentation]
+[Documentation]: https://pdoc3.github.io/pdoc/doc/pdoc/
+
+%package -n python3-pdoc3
+Summary: Auto-generate API documentation for Python projects.
+Provides: python-pdoc3
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-pdoc3
+[![Build Status](https://img.shields.io/github/workflow/status/pdoc3/pdoc/CI?style=for-the-badge)](https://github.com/pdoc3/pdoc/actions)
+[![Code Coverage](https://img.shields.io/codecov/c/gh/pdoc3/pdoc.svg?style=for-the-badge)](https://codecov.io/gh/pdoc3/pdoc)
+[![pdoc3 on PyPI](https://img.shields.io/pypi/v/pdoc3.svg?color=blue&style=for-the-badge)](https://pypi.org/project/pdoc3)
+[![package downloads](https://img.shields.io/pypi/dm/pdoc3.svg?color=skyblue&style=for-the-badge)](https://pypi.org/project/pdoc3)
+[![GitHub Sponsors](https://img.shields.io/github/sponsors/kernc?color=pink&style=for-the-badge)](https://github.com/sponsors/kernc)
+Auto-generate API documentation for Python projects.
+[**Project website**](https://pdoc3.github.io/pdoc/)
+[Documentation]
+[Documentation]: https://pdoc3.github.io/pdoc/doc/pdoc/
+
+%package help
+Summary: Development documents and examples for pdoc3
+Provides: python3-pdoc3-doc
+%description help
+[![Build Status](https://img.shields.io/github/workflow/status/pdoc3/pdoc/CI?style=for-the-badge)](https://github.com/pdoc3/pdoc/actions)
+[![Code Coverage](https://img.shields.io/codecov/c/gh/pdoc3/pdoc.svg?style=for-the-badge)](https://codecov.io/gh/pdoc3/pdoc)
+[![pdoc3 on PyPI](https://img.shields.io/pypi/v/pdoc3.svg?color=blue&style=for-the-badge)](https://pypi.org/project/pdoc3)
+[![package downloads](https://img.shields.io/pypi/dm/pdoc3.svg?color=skyblue&style=for-the-badge)](https://pypi.org/project/pdoc3)
+[![GitHub Sponsors](https://img.shields.io/github/sponsors/kernc?color=pink&style=for-the-badge)](https://github.com/sponsors/kernc)
+Auto-generate API documentation for Python projects.
+[**Project website**](https://pdoc3.github.io/pdoc/)
+[Documentation]
+[Documentation]: https://pdoc3.github.io/pdoc/doc/pdoc/
+
+%prep
+%autosetup -n pdoc3-0.10.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-pdoc3 -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 0.10.0-1
+- Package Spec generated