summaryrefslogtreecommitdiff
path: root/python-pefile.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-03-09 14:58:19 +0000
committerCoprDistGit <infra@openeuler.org>2023-03-09 14:58:19 +0000
commit00eb34b4109a38054c2be33003031d10c54617ac (patch)
tree17044cb7263db9ca012b8ce9a3cd85121f85109b /python-pefile.spec
parent933a8099330001d421db79306df3717878f4690f (diff)
automatic import of python-pefile
Diffstat (limited to 'python-pefile.spec')
-rw-r--r--python-pefile.spec114
1 files changed, 114 insertions, 0 deletions
diff --git a/python-pefile.spec b/python-pefile.spec
new file mode 100644
index 0000000..c882755
--- /dev/null
+++ b/python-pefile.spec
@@ -0,0 +1,114 @@
+%global _empty_manifest_terminate_build 0
+Name: python-pefile
+Version: 2023.2.7
+Release: 1
+Summary: Python PE parsing module
+License: MIT
+URL: https://github.com/erocarrera/pefile
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/78/c5/3b3c62223f72e2360737fd2a57c30e5b2adecd85e70276879609a7403334/pefile-2023.2.7.tar.gz
+BuildArch: noarch
+
+
+%description
+pefile, Portable Executable reader module
+
+All the PE file basic structures are available with their default names as
+attributes of the instance returned.
+
+Processed elements such as the import table are made available with lowercase
+names, to differentiate them from the upper case basic structure names.
+
+pefile has been tested against many edge cases such as corrupted and malformed
+PEs as well as malware, which often attempts to abuse the format way beyond its
+standard use. To the best of my knowledge most of the abuse is handled
+gracefully.
+
+Copyright (c) 2005-2023 Ero Carrera <ero.carrera@gmail.com>
+
+
+%package -n python3-pefile
+Summary: Python PE parsing module
+Provides: python-pefile
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-pefile
+pefile, Portable Executable reader module
+
+All the PE file basic structures are available with their default names as
+attributes of the instance returned.
+
+Processed elements such as the import table are made available with lowercase
+names, to differentiate them from the upper case basic structure names.
+
+pefile has been tested against many edge cases such as corrupted and malformed
+PEs as well as malware, which often attempts to abuse the format way beyond its
+standard use. To the best of my knowledge most of the abuse is handled
+gracefully.
+
+Copyright (c) 2005-2023 Ero Carrera <ero.carrera@gmail.com>
+
+
+%package help
+Summary: Development documents and examples for pefile
+Provides: python3-pefile-doc
+%description help
+pefile, Portable Executable reader module
+
+All the PE file basic structures are available with their default names as
+attributes of the instance returned.
+
+Processed elements such as the import table are made available with lowercase
+names, to differentiate them from the upper case basic structure names.
+
+pefile has been tested against many edge cases such as corrupted and malformed
+PEs as well as malware, which often attempts to abuse the format way beyond its
+standard use. To the best of my knowledge most of the abuse is handled
+gracefully.
+
+Copyright (c) 2005-2023 Ero Carrera <ero.carrera@gmail.com>
+
+
+%prep
+%autosetup -n pefile-2023.2.7
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-pefile -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Thu Mar 09 2023 Python_Bot <Python_Bot@openeuler.org> - 2023.2.7-1
+- Package Spec generated