summaryrefslogtreecommitdiff
path: root/python-pi3dpf-ns-pi3dpf-np.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-pi3dpf-ns-pi3dpf-np.spec')
-rw-r--r--python-pi3dpf-ns-pi3dpf-np.spec168
1 files changed, 168 insertions, 0 deletions
diff --git a/python-pi3dpf-ns-pi3dpf-np.spec b/python-pi3dpf-ns-pi3dpf-np.spec
new file mode 100644
index 0000000..6802191
--- /dev/null
+++ b/python-pi3dpf-ns-pi3dpf-np.spec
@@ -0,0 +1,168 @@
+%global _empty_manifest_terminate_build 0
+Name: python-pi3dpf-ns-pi3dpf-np
+Version: 0.1.31
+Release: 1
+Summary: Module to show whats currently playing on alexa
+License: GPLv3
+URL: https://github.com/satnerd/pi3dpf-pictureframe
+Source0: https://mirrors.aliyun.com/pypi/web/packages/6d/fa/2ca2afc1c7cb6e930a385f59b4ffe4f9533c0f93792c4b6ecad1ff4299ae/pi3dpf_ns_pi3dpf_np-0.1.31.tar.gz
+BuildArch: noarch
+
+
+%description
+# Alexa now playing configuration instructions #
+
+## resolving login problems ##
+
+ INFO: alexa - alexa login failed. If the problem persists, open /home/pi/.pf/logs/alexa_response.html in browser, delete cookies and login
+If you see this message in the log, please login to your Alexa account from the same machine you have the now-playing daemon running.
+In most of the cases, a captcha is provided and once this is done, the daemon can be started without problem.
+
+Keep in mind that there are several URLs used by amazon for authenticating their clients.
+Set the property PI3D_ALEXA_ACCOUNT_BASE_URL accordingly in /home/pi/.pf/pf.config:
+
+ PI3D_ALEXA_ACCOUNT_BASE_URL : https://alexa.amazon.de # Germany
+ PI3D_ALEXA_ACCOUNT_BASE_URL : https://alexa.amazon.com # the rest of the world
+
+
+
+## How to get PI3D_RADIOTIME_PARTNER_ID ##
+If you browse in Chrome or Edge to the page https://alexa.amazon.de/spa/index.html#music/TUNE_IN, and then
+continue to Favorites, the link will extend to something like this:
+https://alexa.amazon.de/spa/index.html#music/TUNE_IN/link/aHR0cDovL29wbWwucmFkaW90aW1lLmNvbS9Ccm93c2UuYXNoeD9jPXByZXNldHMmZm9ybWF0cz1hYWMsbXAzJnBhcnRuZXJJZD0hRWFhYWFhYSZzZXJpYWw9QXh4eHh4eHh4eHh4eHh4eHh4eHh4eHh4eCZsb2NhbGU9ZW4mbGF0bG9uPTM0LjUxMDQ5MCwtODUuMzEyMTExCg
+which is base64 encoded.
+
+Using 'echo aHR0cDovL29wb...| base64 -d', the data-url provides:
+http://opml.radiotime.com/Browse.ashx?c=presets&formats=aac,mp3&partnerId=!Eaaaaaa&serial=Axxxxxxxxxxxxxxxxxxxxxxxx&locale=en&latlon=34.510490,-85.312111
+
+
+ echo aHR0cDovL29wb...| base64 -d
+ http://opml.radiotime.com/Browse.ashx?c=presets&formats=aac,mp3&partnerId=!Eaaaaaa&serial=Axxxxxxxxxxxxxxxxxxxxxxxx&locale=en&latlon=34.510490,-85.312111
+
+Remarks: adding &render=json to the url will return JSON.
+
+ add the following line to your config file /home/pi/.pf/pf_secrets:
+ radio_time_partner_id: !Eaaaaaa
+
+%package -n python3-pi3dpf-ns-pi3dpf-np
+Summary: Module to show whats currently playing on alexa
+Provides: python-pi3dpf-ns-pi3dpf-np
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-pi3dpf-ns-pi3dpf-np
+# Alexa now playing configuration instructions #
+
+## resolving login problems ##
+
+ INFO: alexa - alexa login failed. If the problem persists, open /home/pi/.pf/logs/alexa_response.html in browser, delete cookies and login
+If you see this message in the log, please login to your Alexa account from the same machine you have the now-playing daemon running.
+In most of the cases, a captcha is provided and once this is done, the daemon can be started without problem.
+
+Keep in mind that there are several URLs used by amazon for authenticating their clients.
+Set the property PI3D_ALEXA_ACCOUNT_BASE_URL accordingly in /home/pi/.pf/pf.config:
+
+ PI3D_ALEXA_ACCOUNT_BASE_URL : https://alexa.amazon.de # Germany
+ PI3D_ALEXA_ACCOUNT_BASE_URL : https://alexa.amazon.com # the rest of the world
+
+
+
+## How to get PI3D_RADIOTIME_PARTNER_ID ##
+If you browse in Chrome or Edge to the page https://alexa.amazon.de/spa/index.html#music/TUNE_IN, and then
+continue to Favorites, the link will extend to something like this:
+https://alexa.amazon.de/spa/index.html#music/TUNE_IN/link/aHR0cDovL29wbWwucmFkaW90aW1lLmNvbS9Ccm93c2UuYXNoeD9jPXByZXNldHMmZm9ybWF0cz1hYWMsbXAzJnBhcnRuZXJJZD0hRWFhYWFhYSZzZXJpYWw9QXh4eHh4eHh4eHh4eHh4eHh4eHh4eHh4eCZsb2NhbGU9ZW4mbGF0bG9uPTM0LjUxMDQ5MCwtODUuMzEyMTExCg
+which is base64 encoded.
+
+Using 'echo aHR0cDovL29wb...| base64 -d', the data-url provides:
+http://opml.radiotime.com/Browse.ashx?c=presets&formats=aac,mp3&partnerId=!Eaaaaaa&serial=Axxxxxxxxxxxxxxxxxxxxxxxx&locale=en&latlon=34.510490,-85.312111
+
+
+ echo aHR0cDovL29wb...| base64 -d
+ http://opml.radiotime.com/Browse.ashx?c=presets&formats=aac,mp3&partnerId=!Eaaaaaa&serial=Axxxxxxxxxxxxxxxxxxxxxxxx&locale=en&latlon=34.510490,-85.312111
+
+Remarks: adding &render=json to the url will return JSON.
+
+ add the following line to your config file /home/pi/.pf/pf_secrets:
+ radio_time_partner_id: !Eaaaaaa
+
+%package help
+Summary: Development documents and examples for pi3dpf-ns-pi3dpf-np
+Provides: python3-pi3dpf-ns-pi3dpf-np-doc
+%description help
+# Alexa now playing configuration instructions #
+
+## resolving login problems ##
+
+ INFO: alexa - alexa login failed. If the problem persists, open /home/pi/.pf/logs/alexa_response.html in browser, delete cookies and login
+If you see this message in the log, please login to your Alexa account from the same machine you have the now-playing daemon running.
+In most of the cases, a captcha is provided and once this is done, the daemon can be started without problem.
+
+Keep in mind that there are several URLs used by amazon for authenticating their clients.
+Set the property PI3D_ALEXA_ACCOUNT_BASE_URL accordingly in /home/pi/.pf/pf.config:
+
+ PI3D_ALEXA_ACCOUNT_BASE_URL : https://alexa.amazon.de # Germany
+ PI3D_ALEXA_ACCOUNT_BASE_URL : https://alexa.amazon.com # the rest of the world
+
+
+
+## How to get PI3D_RADIOTIME_PARTNER_ID ##
+If you browse in Chrome or Edge to the page https://alexa.amazon.de/spa/index.html#music/TUNE_IN, and then
+continue to Favorites, the link will extend to something like this:
+https://alexa.amazon.de/spa/index.html#music/TUNE_IN/link/aHR0cDovL29wbWwucmFkaW90aW1lLmNvbS9Ccm93c2UuYXNoeD9jPXByZXNldHMmZm9ybWF0cz1hYWMsbXAzJnBhcnRuZXJJZD0hRWFhYWFhYSZzZXJpYWw9QXh4eHh4eHh4eHh4eHh4eHh4eHh4eHh4eCZsb2NhbGU9ZW4mbGF0bG9uPTM0LjUxMDQ5MCwtODUuMzEyMTExCg
+which is base64 encoded.
+
+Using 'echo aHR0cDovL29wb...| base64 -d', the data-url provides:
+http://opml.radiotime.com/Browse.ashx?c=presets&formats=aac,mp3&partnerId=!Eaaaaaa&serial=Axxxxxxxxxxxxxxxxxxxxxxxx&locale=en&latlon=34.510490,-85.312111
+
+
+ echo aHR0cDovL29wb...| base64 -d
+ http://opml.radiotime.com/Browse.ashx?c=presets&formats=aac,mp3&partnerId=!Eaaaaaa&serial=Axxxxxxxxxxxxxxxxxxxxxxxx&locale=en&latlon=34.510490,-85.312111
+
+Remarks: adding &render=json to the url will return JSON.
+
+ add the following line to your config file /home/pi/.pf/pf_secrets:
+ radio_time_partner_id: !Eaaaaaa
+
+%prep
+%autosetup -n pi3dpf_ns_pi3dpf_np-0.1.31
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-pi3dpf-ns-pi3dpf-np -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Jun 20 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.31-1
+- Package Spec generated