summaryrefslogtreecommitdiff
path: root/python-pickle-mixin.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-10 23:54:11 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-10 23:54:11 +0000
commit9e36d449fa470d36c42386747261ab23f926efa8 (patch)
treeced1505548fe37032e91a7a3bab7a30df96108c1 /python-pickle-mixin.spec
parentf2526b8a7870100c751973889771651864e348a5 (diff)
automatic import of python-pickle-mixin
Diffstat (limited to 'python-pickle-mixin.spec')
-rw-r--r--python-pickle-mixin.spec75
1 files changed, 75 insertions, 0 deletions
diff --git a/python-pickle-mixin.spec b/python-pickle-mixin.spec
new file mode 100644
index 0000000..5f3382d
--- /dev/null
+++ b/python-pickle-mixin.spec
@@ -0,0 +1,75 @@
+%global _empty_manifest_terminate_build 0
+Name: python-pickle-mixin
+Version: 1.0.2
+Release: 1
+Summary: Makes un-pickle-able objects pick-able.
+License: MIT
+URL: https://github.com/limix/pickle-mixin
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/02/77/9d5eb2201bbc130e2a5cc41fc949e4ab0da74b619107eac1c511be3af7a7/pickle-mixin-1.0.2.tar.gz
+BuildArch: noarch
+
+
+%description
+|PyPI-License| |PyPI-Version|
+Makes un-pickle-able objects pick-able.
+
+%package -n python3-pickle-mixin
+Summary: Makes un-pickle-able objects pick-able.
+Provides: python-pickle-mixin
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-pickle-mixin
+|PyPI-License| |PyPI-Version|
+Makes un-pickle-able objects pick-able.
+
+%package help
+Summary: Development documents and examples for pickle-mixin
+Provides: python3-pickle-mixin-doc
+%description help
+|PyPI-License| |PyPI-Version|
+Makes un-pickle-able objects pick-able.
+
+%prep
+%autosetup -n pickle-mixin-1.0.2
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-pickle-mixin -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.2-1
+- Package Spec generated