summaryrefslogtreecommitdiff
path: root/python-picos.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-picos.spec')
-rw-r--r--python-picos.spec96
1 files changed, 96 insertions, 0 deletions
diff --git a/python-picos.spec b/python-picos.spec
new file mode 100644
index 0000000..5653a0c
--- /dev/null
+++ b/python-picos.spec
@@ -0,0 +1,96 @@
+%global _empty_manifest_terminate_build 0
+Name: python-PICOS
+Version: 2.4.17
+Release: 1
+Summary: A Python interface to conic optimization solvers.
+License: GNU General Public License v3 (GPLv3)
+URL: https://pypi.org/project/PICOS/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/01/01/4429e9ee469d79d64d741bd6ce90604c39cec51d63fe2822f311f8555d4d/PICOS-2.4.17.tar.gz
+BuildArch: noarch
+
+
+%description
+PICOS is a user friendly Python API to several conic and integer programming
+solvers, designed to be used by both application developers and researchers as
+well as instructors teaching courses on mathematical optimization. It allows you
+to enter an optimization problem as a **high level model**, with painless
+support for **(complex) vector and matrix variables** and **multidimensional
+algebra**. Your model will be transformed to the standard form understood by an
+appropriate solver that is available at runtime. This makes your application
+**portable** as users have the choice between several commercial and open source
+solvers.
+
+%package -n python3-PICOS
+Summary: A Python interface to conic optimization solvers.
+Provides: python-PICOS
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-PICOS
+PICOS is a user friendly Python API to several conic and integer programming
+solvers, designed to be used by both application developers and researchers as
+well as instructors teaching courses on mathematical optimization. It allows you
+to enter an optimization problem as a **high level model**, with painless
+support for **(complex) vector and matrix variables** and **multidimensional
+algebra**. Your model will be transformed to the standard form understood by an
+appropriate solver that is available at runtime. This makes your application
+**portable** as users have the choice between several commercial and open source
+solvers.
+
+%package help
+Summary: Development documents and examples for PICOS
+Provides: python3-PICOS-doc
+%description help
+PICOS is a user friendly Python API to several conic and integer programming
+solvers, designed to be used by both application developers and researchers as
+well as instructors teaching courses on mathematical optimization. It allows you
+to enter an optimization problem as a **high level model**, with painless
+support for **(complex) vector and matrix variables** and **multidimensional
+algebra**. Your model will be transformed to the standard form understood by an
+appropriate solver that is available at runtime. This makes your application
+**portable** as users have the choice between several commercial and open source
+solvers.
+
+%prep
+%autosetup -n PICOS-2.4.17
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-PICOS -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 2.4.17-1
+- Package Spec generated