summaryrefslogtreecommitdiff
path: root/python-pike.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-pike.spec')
-rw-r--r--python-pike.spec97
1 files changed, 97 insertions, 0 deletions
diff --git a/python-pike.spec b/python-pike.spec
new file mode 100644
index 0000000..d99c9d7
--- /dev/null
+++ b/python-pike.spec
@@ -0,0 +1,97 @@
+%global _empty_manifest_terminate_build 0
+Name: python-pike
+Version: 0.1.1
+Release: 1
+Summary: Lightweight plugin management system for Python
+License: Apache v2
+URL: https://github.com/pyarmory/pike
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/47/c5/f5408064406e1601f6fa25bd70c913a8f2e1a4dc37ebde92e70b4fc5ae9c/pike-0.1.1.tar.gz
+BuildArch: noarch
+
+Requires: python3-six
+
+%description
+Pike is a dynamic plugin management library for Python. Unlike most Python
+plugin managers, Pike allows for you to load Python packages from anywhere
+on a filesystem without complicated configuration. This enables applications
+to easily add the ability to expand their functionality through plugin modules.
+In addition to plugin management, Pike also includes a set of discovery
+functions for custom module and class discovery.
+* Documentation: ReadTheDocs_
+* CI: Travis_
+* Coverage: CodeCov_
+
+%package -n python3-pike
+Summary: Lightweight plugin management system for Python
+Provides: python-pike
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-pike
+Pike is a dynamic plugin management library for Python. Unlike most Python
+plugin managers, Pike allows for you to load Python packages from anywhere
+on a filesystem without complicated configuration. This enables applications
+to easily add the ability to expand their functionality through plugin modules.
+In addition to plugin management, Pike also includes a set of discovery
+functions for custom module and class discovery.
+* Documentation: ReadTheDocs_
+* CI: Travis_
+* Coverage: CodeCov_
+
+%package help
+Summary: Development documents and examples for pike
+Provides: python3-pike-doc
+%description help
+Pike is a dynamic plugin management library for Python. Unlike most Python
+plugin managers, Pike allows for you to load Python packages from anywhere
+on a filesystem without complicated configuration. This enables applications
+to easily add the ability to expand their functionality through plugin modules.
+In addition to plugin management, Pike also includes a set of discovery
+functions for custom module and class discovery.
+* Documentation: ReadTheDocs_
+* CI: Travis_
+* Coverage: CodeCov_
+
+%prep
+%autosetup -n pike-0.1.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-pike -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Thu May 18 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.1-1
+- Package Spec generated