summaryrefslogtreecommitdiff
path: root/python-poppy.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-poppy.spec')
-rw-r--r--python-poppy.spec88
1 files changed, 88 insertions, 0 deletions
diff --git a/python-poppy.spec b/python-poppy.spec
new file mode 100644
index 0000000..e491c1d
--- /dev/null
+++ b/python-poppy.spec
@@ -0,0 +1,88 @@
+%global _empty_manifest_terminate_build 0
+Name: python-poppy
+Version: 1.0.3
+Release: 1
+Summary: Physical optics propagation (wavefront diffraction) for optical simulations, particularly of telescopes.
+License: BSD
+URL: https://poppy-optics.readthedocs.io/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/b3/68/90edb4ff089579e3145eac7d7e8e0b3afa41a7bca639ca0fe0ce3da428f0/poppy-1.0.3.tar.gz
+BuildArch: noarch
+
+Requires: python3-numpy
+Requires: python3-scipy
+Requires: python3-matplotlib
+Requires: python3-astropy
+Requires: python3-synphot
+Requires: python3-nbsphinx
+Requires: python3-stsci-rtd-theme
+Requires: python3-sphinx-astropy
+Requires: python3-sphinx-rtd-theme
+Requires: python3-sphinx-automodapi
+Requires: python3-sphinx-issues
+Requires: python3-pytest
+Requires: python3-pytest-astropy
+
+%description
+"POPPY (**P**\ hysical **O**\ ptics **P**\ ropagation in **Py**\ thon) is a Python package that simulates physical optical propagation including diffraction. It implements a flexible framework for modeling Fraunhofer and Fresnel diffraction and point spread function formation, particularly in the context of astronomical telescopes."
+
+
+%package -n python3-poppy
+Summary: Physical optics propagation (wavefront diffraction) for optical simulations, particularly of telescopes.
+Provides: python-poppy
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-poppy
+"POPPY (**P**\ hysical **O**\ ptics **P**\ ropagation in **Py**\ thon) is a Python package that simulates physical optical propagation including diffraction. It implements a flexible framework for modeling Fraunhofer and Fresnel diffraction and point spread function formation, particularly in the context of astronomical telescopes."
+
+
+%package help
+Summary: Development documents and examples for poppy
+Provides: python3-poppy-doc
+%description help
+"POPPY (**P**\ hysical **O**\ ptics **P**\ ropagation in **Py**\ thon) is a Python package that simulates physical optical propagation including diffraction. It implements a flexible framework for modeling Fraunhofer and Fresnel diffraction and point spread function formation, particularly in the context of astronomical telescopes."
+
+
+%prep
+%autosetup -n poppy-1.0.3
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-poppy -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.3-1
+- Package Spec generated