summaryrefslogtreecommitdiff
path: root/python-proto-parser.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-proto-parser.spec')
-rw-r--r--python-proto-parser.spec72
1 files changed, 72 insertions, 0 deletions
diff --git a/python-proto-parser.spec b/python-proto-parser.spec
new file mode 100644
index 0000000..289c9ee
--- /dev/null
+++ b/python-proto-parser.spec
@@ -0,0 +1,72 @@
+%global _empty_manifest_terminate_build 0
+Name: python-proto-parser
+Version: 1.6.3
+Release: 1
+Summary: A package for parsing proto files
+License: Apache Software License
+URL: https://github.com/khadgarmage/protoparser
+Source0: https://mirrors.aliyun.com/pypi/web/packages/93/94/d7140816780c061e6963e1afa2878c67bf16da920713631fae4de106387e/proto-parser-1.6.3.tar.gz
+BuildArch: noarch
+
+
+%description
+
+
+%package -n python3-proto-parser
+Summary: A package for parsing proto files
+Provides: python-proto-parser
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-proto-parser
+
+
+%package help
+Summary: Development documents and examples for proto-parser
+Provides: python3-proto-parser-doc
+%description help
+
+
+%prep
+%autosetup -n proto-parser-1.6.3
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-proto-parser -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Jun 20 2023 Python_Bot <Python_Bot@openeuler.org> - 1.6.3-1
+- Package Spec generated