summaryrefslogtreecommitdiff
path: root/python-psf-utils.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-psf-utils.spec')
-rw-r--r--python-psf-utils.spec78
1 files changed, 78 insertions, 0 deletions
diff --git a/python-psf-utils.spec b/python-psf-utils.spec
new file mode 100644
index 0000000..471a178
--- /dev/null
+++ b/python-psf-utils.spec
@@ -0,0 +1,78 @@
+%global _empty_manifest_terminate_build 0
+Name: python-psf-utils
+Version: 1.6.0
+Release: 1
+Summary: Cadence PSF file utilities
+License: GPLv3+
+URL: https://psf_utils.readthedocs.io
+Source0: https://mirrors.aliyun.com/pypi/web/packages/b4/f5/521ff8811898637eb361e947b7e611058b89dc265af6127aeabb5870962f/psf_utils-1.6.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-docopt
+Requires: python3-inform
+Requires: python3-matplotlib
+Requires: python3-numpy
+Requires: python3-ply
+Requires: python3-quantiphy
+
+%description
+ https://github.com/KenKundert/psf_utils/actions/workflows/build.yaml/badge.svg
+
+%package -n python3-psf-utils
+Summary: Cadence PSF file utilities
+Provides: python-psf-utils
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-psf-utils
+ https://github.com/KenKundert/psf_utils/actions/workflows/build.yaml/badge.svg
+
+%package help
+Summary: Development documents and examples for psf-utils
+Provides: python3-psf-utils-doc
+%description help
+ https://github.com/KenKundert/psf_utils/actions/workflows/build.yaml/badge.svg
+
+%prep
+%autosetup -n psf_utils-1.6.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-psf-utils -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Jun 20 2023 Python_Bot <Python_Bot@openeuler.org> - 1.6.0-1
+- Package Spec generated