summaryrefslogtreecommitdiff
path: root/python-pulp-file-client.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-pulp-file-client.spec')
-rw-r--r--python-pulp-file-client.spec85
1 files changed, 85 insertions, 0 deletions
diff --git a/python-pulp-file-client.spec b/python-pulp-file-client.spec
new file mode 100644
index 0000000..d0cc7f6
--- /dev/null
+++ b/python-pulp-file-client.spec
@@ -0,0 +1,85 @@
+%global _empty_manifest_terminate_build 0
+Name: python-pulp-file-client
+Version: 1.14.0
+Release: 1
+Summary: Pulp 3 API
+License: GPLv2+
+URL: https://pypi.org/project/pulp-file-client/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/b9/cf/040f280b65063185e7363dbfd1e42ed2521febe7f45d6bb87d819ff91b77/pulp_file-client-1.14.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-urllib3
+Requires: python3-six
+Requires: python3-certifi
+Requires: python3-dateutil
+
+%description
+Fetch, Upload, Organize, and Distribute Software Packages # noqa: E501
+
+
+
+
+%package -n python3-pulp-file-client
+Summary: Pulp 3 API
+Provides: python-pulp-file-client
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-pulp-file-client
+Fetch, Upload, Organize, and Distribute Software Packages # noqa: E501
+
+
+
+
+%package help
+Summary: Development documents and examples for pulp-file-client
+Provides: python3-pulp-file-client-doc
+%description help
+Fetch, Upload, Organize, and Distribute Software Packages # noqa: E501
+
+
+
+
+%prep
+%autosetup -n pulp-file-client-1.14.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-pulp-file-client -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 1.14.0-1
+- Package Spec generated