summaryrefslogtreecommitdiff
path: root/python-pulsar.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-11 09:53:42 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-11 09:53:42 +0000
commit360ccff07bcb5565170b1d57c2280163e1aef141 (patch)
treec608e4f9a3963c6e046941e8a4690138970ef024 /python-pulsar.spec
parenteead601d946a60763f7c4a1c7e119bc3c0777b01 (diff)
automatic import of python-pulsar
Diffstat (limited to 'python-pulsar.spec')
-rw-r--r--python-pulsar.spec94
1 files changed, 94 insertions, 0 deletions
diff --git a/python-pulsar.spec b/python-pulsar.spec
new file mode 100644
index 0000000..b5e2632
--- /dev/null
+++ b/python-pulsar.spec
@@ -0,0 +1,94 @@
+%global _empty_manifest_terminate_build 0
+Name: python-pulsar
+Version: 2.0.2
+Release: 1
+Summary: Event driven concurrent framework for Python
+License: BSD
+URL: https://github.com/quantmind/pulsar
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/d5/6a/f930223a3df2933a76f117e1b16a6b0eb88d263daf51619b0d016745143b/pulsar-2.0.2.tar.gz
+BuildArch: noarch
+
+Requires: python3-multidict
+
+%description
+Pulsar has one **hard dependency**:
+* multidict_
+install via pip::
+ pip install pulsar
+or download the tarball from pypi_.
+To speedup pulsar by a factor of 2 or more these **soft dependencies** are recommended
+* httptools_
+* uvloop_
+
+%package -n python3-pulsar
+Summary: Event driven concurrent framework for Python
+Provides: python-pulsar
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-pulsar
+Pulsar has one **hard dependency**:
+* multidict_
+install via pip::
+ pip install pulsar
+or download the tarball from pypi_.
+To speedup pulsar by a factor of 2 or more these **soft dependencies** are recommended
+* httptools_
+* uvloop_
+
+%package help
+Summary: Development documents and examples for pulsar
+Provides: python3-pulsar-doc
+%description help
+Pulsar has one **hard dependency**:
+* multidict_
+install via pip::
+ pip install pulsar
+or download the tarball from pypi_.
+To speedup pulsar by a factor of 2 or more these **soft dependencies** are recommended
+* httptools_
+* uvloop_
+
+%prep
+%autosetup -n pulsar-2.0.2
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-pulsar -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 2.0.2-1
+- Package Spec generated