summaryrefslogtreecommitdiff
path: root/python-py42.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-py42.spec')
-rw-r--r--python-py42.spec19
1 files changed, 10 insertions, 9 deletions
diff --git a/python-py42.spec b/python-py42.spec
index 2a7d6d8..a8d5395 100644
--- a/python-py42.spec
+++ b/python-py42.spec
@@ -1,13 +1,14 @@
%global _empty_manifest_terminate_build 0
Name: python-py42
-Version: 1.26.1
+Version: 1.26.2
Release: 1
Summary: The Official Code42 Python API Client
License: MIT License
URL: https://github.com/code42/py42
-Source0: https://mirrors.nju.edu.cn/pypi/web/packages/34/4d/4857787432953c675e9c783e52e616aa5c8f52a0d853b1652c56473e1cda/py42-1.26.1.tar.gz
+Source0: https://mirrors.aliyun.com/pypi/web/packages/db/bb/042a742ec7b6582ef2535a0212ac664dad89bfd59243c870a02a262ef42c/py42-1.26.2.tar.gz
BuildArch: noarch
+Requires: python3-urllib3
Requires: python3-requests
Requires: python3-flake8
Requires: python3-pytest
@@ -548,7 +549,7 @@ For complete documentation on the Code42 web API that backs this SDK, here are s
%prep
-%autosetup -n py42-1.26.1
+%autosetup -n py42-1.26.2
%build
%py3_build
@@ -562,20 +563,20 @@ if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
- find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
- find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
- find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
- find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
- find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
@@ -588,5 +589,5 @@ mv %{buildroot}/doclist.lst .
%{_docdir}/*
%changelog
-* Mon May 15 2023 Python_Bot <Python_Bot@openeuler.org> - 1.26.1-1
+* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 1.26.2-1
- Package Spec generated