summaryrefslogtreecommitdiff
path: root/python-pybutton.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-15 04:52:57 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-15 04:52:57 +0000
commitd19bbe69eecdba8116487eaf1b93e8744563ac76 (patch)
treea4ab35097c50bb48d30fe728387938d27583097f /python-pybutton.spec
parentc236ad276378ac56dc4dca7bf492e83ecfc3be20 (diff)
automatic import of python-pybutton
Diffstat (limited to 'python-pybutton.spec')
-rw-r--r--python-pybutton.spec105
1 files changed, 105 insertions, 0 deletions
diff --git a/python-pybutton.spec b/python-pybutton.spec
new file mode 100644
index 0000000..2d27a30
--- /dev/null
+++ b/python-pybutton.spec
@@ -0,0 +1,105 @@
+%global _empty_manifest_terminate_build 0
+Name: python-pybutton
+Version: 3.0.0
+Release: 1
+Summary: Client for the Button API
+License: MIT
+URL: https://www.usebutton.com/developers/api-reference/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/66/60/5f99534841b44712d0db5606fedd661c1892315182521794da2b4e525050/pybutton-3.0.0.tar.gz
+BuildArch: noarch
+
+
+%description
+This module is a thin client for interacting with Button's API.
+Please see the full `API
+Docs <https://www.usebutton.com/developers/api-reference>`__ for more
+information. For help, check out our
+`Support <https://www.usebutton.com/support>`__ page or `get in
+touch <https://www.usebutton.com/contact>`__.
+Supported runtimes
+^^^^^^^^^^^^^^^^^^
+- cPython ``2.7``, ``3.4``, ``3.5``, ``3.6``, ``3.7``
+Dependencies
+^^^^^^^^^^^^
+- None
+
+%package -n python3-pybutton
+Summary: Client for the Button API
+Provides: python-pybutton
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-pybutton
+This module is a thin client for interacting with Button's API.
+Please see the full `API
+Docs <https://www.usebutton.com/developers/api-reference>`__ for more
+information. For help, check out our
+`Support <https://www.usebutton.com/support>`__ page or `get in
+touch <https://www.usebutton.com/contact>`__.
+Supported runtimes
+^^^^^^^^^^^^^^^^^^
+- cPython ``2.7``, ``3.4``, ``3.5``, ``3.6``, ``3.7``
+Dependencies
+^^^^^^^^^^^^
+- None
+
+%package help
+Summary: Development documents and examples for pybutton
+Provides: python3-pybutton-doc
+%description help
+This module is a thin client for interacting with Button's API.
+Please see the full `API
+Docs <https://www.usebutton.com/developers/api-reference>`__ for more
+information. For help, check out our
+`Support <https://www.usebutton.com/support>`__ page or `get in
+touch <https://www.usebutton.com/contact>`__.
+Supported runtimes
+^^^^^^^^^^^^^^^^^^
+- cPython ``2.7``, ``3.4``, ``3.5``, ``3.6``, ``3.7``
+Dependencies
+^^^^^^^^^^^^
+- None
+
+%prep
+%autosetup -n pybutton-3.0.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-pybutton -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon May 15 2023 Python_Bot <Python_Bot@openeuler.org> - 3.0.0-1
+- Package Spec generated