summaryrefslogtreecommitdiff
path: root/python-pycerver.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-pycerver.spec')
-rw-r--r--python-pycerver.spec72
1 files changed, 72 insertions, 0 deletions
diff --git a/python-pycerver.spec b/python-pycerver.spec
new file mode 100644
index 0000000..01ac525
--- /dev/null
+++ b/python-pycerver.spec
@@ -0,0 +1,72 @@
+%global _empty_manifest_terminate_build 0
+Name: python-pycerver
+Version: 0.9.7
+Release: 1
+Summary: PyCerver is a pure Python wrapper around the cerver framework
+License: MIT License
+URL: https://github.com/ermiry-com/py-cerver
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/c5/d3/a2d22cdd9d8056d4b72264cb1bc1d97a8cf241ff460d2108c0e5b4c13a72/pycerver-0.9.7.tar.gz
+BuildArch: noarch
+
+
+%description
+Ermiry - Never Stop Creating
+
+%package -n python3-pycerver
+Summary: PyCerver is a pure Python wrapper around the cerver framework
+Provides: python-pycerver
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-pycerver
+Ermiry - Never Stop Creating
+
+%package help
+Summary: Development documents and examples for pycerver
+Provides: python3-pycerver-doc
+%description help
+Ermiry - Never Stop Creating
+
+%prep
+%autosetup -n pycerver-0.9.7
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-pycerver -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon May 29 2023 Python_Bot <Python_Bot@openeuler.org> - 0.9.7-1
+- Package Spec generated