summaryrefslogtreecommitdiff
path: root/python-pyclipper.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-pyclipper.spec')
-rw-r--r--python-pyclipper.spec95
1 files changed, 95 insertions, 0 deletions
diff --git a/python-pyclipper.spec b/python-pyclipper.spec
new file mode 100644
index 0000000..7523542
--- /dev/null
+++ b/python-pyclipper.spec
@@ -0,0 +1,95 @@
+%global _empty_manifest_terminate_build 0
+Name: python-pyclipper
+Version: 1.3.0.post4
+Release: 1
+Summary: Cython wrapper for the C++ translation of the Angus Johnson's Clipper library (ver. 6.4.2)
+License: MIT
+URL: https://github.com/greginvm/pyclipper
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/dd/03/09e2415b72b470851588dfc7c9b7b4f410a79ed8e2c6c1fb25dfec789b70/pyclipper-1.3.0.post4.tar.gz
+
+
+%description
+Pyclipper is a Cython wrapper exposing public functions and classes of
+the C++ translation of the `Angus Johnson's Clipper library (ver.
+6.4.2) <http://www.angusj.com/delphi/clipper.php>`__.
+Pyclipper releases were tested with Python 2.7 and 3.4 on Linux (Ubuntu
+14.04, x64) and Windows (8.1, x64).
+Source code is available on
+`GitHub <https://github.com/fonttools/pyclipper>`__. The package is published on
+`PyPI <https://pypi.python.org/pypi/pyclipper>`__.
+
+%package -n python3-pyclipper
+Summary: Cython wrapper for the C++ translation of the Angus Johnson's Clipper library (ver. 6.4.2)
+Provides: python-pyclipper
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+BuildRequires: python3-cffi
+BuildRequires: gcc
+BuildRequires: gdb
+%description -n python3-pyclipper
+Pyclipper is a Cython wrapper exposing public functions and classes of
+the C++ translation of the `Angus Johnson's Clipper library (ver.
+6.4.2) <http://www.angusj.com/delphi/clipper.php>`__.
+Pyclipper releases were tested with Python 2.7 and 3.4 on Linux (Ubuntu
+14.04, x64) and Windows (8.1, x64).
+Source code is available on
+`GitHub <https://github.com/fonttools/pyclipper>`__. The package is published on
+`PyPI <https://pypi.python.org/pypi/pyclipper>`__.
+
+%package help
+Summary: Development documents and examples for pyclipper
+Provides: python3-pyclipper-doc
+%description help
+Pyclipper is a Cython wrapper exposing public functions and classes of
+the C++ translation of the `Angus Johnson's Clipper library (ver.
+6.4.2) <http://www.angusj.com/delphi/clipper.php>`__.
+Pyclipper releases were tested with Python 2.7 and 3.4 on Linux (Ubuntu
+14.04, x64) and Windows (8.1, x64).
+Source code is available on
+`GitHub <https://github.com/fonttools/pyclipper>`__. The package is published on
+`PyPI <https://pypi.python.org/pypi/pyclipper>`__.
+
+%prep
+%autosetup -n pyclipper-1.3.0.post4
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-pyclipper -f filelist.lst
+%dir %{python3_sitearch}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Thu Mar 09 2023 Python_Bot <Python_Bot@openeuler.org> - 1.3.0.post4-1
+- Package Spec generated